jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julien Poffet <julienpof...@gmail.com>
Subject Re: tmp files filling up tomcat
Date Tue, 01 Dec 2009 14:22:16 GMT
Hi all,

Still no idea on how I can avoid theses temporary files?

Thanks,
Julien

On Thu, Nov 26, 2009 at 3:10 PM, Julien Poffet <julienpoffet@gmail.com>wrote:

> Hi,
>
> I just read about migration support on
> http://jackrabbit.apache.org/standalone-server.html#StandaloneServer-Backupandmigration
> :
>
> Note that the source repository must not be running when you use this
> feature. If the target repository already exist, then all content inside it
> is overwritten. Note also that the search indexes of the target repository
> will be generated only when the repository is next started. This keeps the
> disk size of the backup smaller, but causes a notable startup delay
> especially for large repositories if you need to restore that backup.
>
> Unfortunately it is not acceptable that the target repository will be
> completely overwritten...
>
> That was probably one of the reason why I get into the importation over
> WebDav thing...
>
> Any other idea?
>
> Cheers,
> Julien
>
>
>
>
>
>
> On Thu, Nov 26, 2009 at 3:05 PM, Julien Poffet <julienpoffet@gmail.com>wrote:
>
>> Hi,
>>
>> Ok I'll give it a try...
>>
>> We can't upgrade to 1.6 due to some library dependency. But our version of
>> 1.5.7 is now almost a 1.6 due to our custom patches ;-)
>>
>> The will upgrade later to 1.6 but right now we have to make this
>> importation with the 1.5.7 and this temporary cache files is a problem that
>> we have to solve ASAP...
>>
>> Thanks for your help
>>
>> Best regards,
>> Julien
>>
>> On Thu, Nov 26, 2009 at 2:51 PM, Jukka Zitting <jukka.zitting@gmail.com>wrote:
>>
>>> Hi,
>>>
>>> On Thu, Nov 26, 2009 at 2:40 PM, Julien Poffet <julienpoffet@gmail.com>
>>> wrote:
>>> > Actually I run the version 1.6 for the source WebDav but my target
>>> > repository runs under the version 1.5.7 of Jackrabbit.
>>> >
>>> > Since the version of my target repository is lower than 1.6 it wouldn't
>>> > work? right?
>>>
>>> Not sure. There hasn't been major changes to the persistence formats,
>>> so depending a bit on your choice of persistence managers it might
>>> just work. At least it's probably worth a try.
>>>
>>> Is there a reason why you can't upgrade the target repository to 1.6?
>>>
>>> BR,
>>>
>>> Jukka Zitting
>>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message