jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Short <...@benshort.co.uk>
Subject Re: list of jars needed for jackrabbit 2.0
Date Thu, 17 Dec 2009 09:40:59 GMT
Hi,

Using the maven dependancy tool I see that Jackrabbit requires the following..

[INFO] +- org.apache.jackrabbit:jackrabbit-core:jar:2.0-beta4:compile
[INFO] |  +- concurrent:concurrent:jar:1.3.4:compile
[INFO] |  +- commons-collections:commons-collections:jar:3.2.1:compile
[INFO] |  +- commons-io:commons-io:jar:1.4:compile
[INFO] |  +- commons-dbcp:commons-dbcp:jar:1.2.2:compile
[INFO] |  |  \- commons-pool:commons-pool:jar:1.3:compile
[INFO] |  +- org.apache.jackrabbit:jackrabbit-api:jar:2.0-beta4:compile
[INFO] |  +- org.apache.jackrabbit:jackrabbit-jcr-commons:jar:2.0-beta4:compile
[INFO] |  +- org.apache.jackrabbit:jackrabbit-spi-commons:jar:2.0-beta4:compile
[INFO] |  +- org.apache.jackrabbit:jackrabbit-spi:jar:2.0-beta4:compile
[INFO] |  +- org.apache.tika:tika-parsers:jar:0.5:compile
[INFO] |  |  +- org.apache.tika:tika-core:jar:0.5:compile
[INFO] |  |  +- org.apache.commons:commons-compress:jar:1.0:compile
[INFO] |  |  +- org.apache.pdfbox:pdfbox:jar:0.8.0-incubating:compile
[INFO] |  |  |  +- org.apache.pdfbox:fontbox:jar:0.8.0-incubator:compile
[INFO] |  |  |  \- org.apache.pdfbox:jempbox:jar:0.8.0-incubator:compile
[INFO] |  |  +- org.apache.poi:poi:jar:3.5-FINAL:compile
[INFO] |  |  +- org.apache.poi:poi-scratchpad:jar:3.5-FINAL:compile
[INFO] |  |  +- org.apache.poi:poi-ooxml:jar:3.5-FINAL:compile
[INFO] |  |  |  \- org.apache.poi:ooxml-schemas:jar:1.0:compile
[INFO] |  |  |     \- org.apache.xmlbeans:xmlbeans:jar:2.3.0:compile
[INFO] |  |  +-
org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:jar:1.0.1:compile
[INFO] |  |  +- org.ccil.cowan.tagsoup:tagsoup:jar:1.2:compile
[INFO] |  |  +- asm:asm:jar:3.1:compile
[INFO] |  |  \- com.drewnoakes:metadata-extractor:jar:2.4.0-beta-1:compile
[INFO] |  +- org.slf4j:slf4j-api:jar:1.5.8:compile
[INFO] |  +- org.slf4j:jcl-over-slf4j:jar:1.5.8:compile
[INFO] |  +- org.apache.lucene:lucene-core:jar:2.4.1:compile
[INFO] |  \- org.apache.derby:derby:jar:10.5.3.0_1:compile

I hope this helps

Ben

2009/12/17 anand <simer.anand88@gmail.com>:
>
> Hello Users,
>
>                    Can anybody tell me about number and name  of jars
> required to run repository.  I was actually running jackrabbit 1.5.6 before
> and these are the jar i used for jackrabbit 2.0 but still it's not running.
>
>
> jcr-1.0.jar:
> jackrabbit-jcr-commons-2.0-beta3.jar          nekohtml-1.9.9.jar
> jackrabbit-jcr-server-2.0-beta3.jar               pdfbox-0.7.3.jar
> poi-3.0.2-FINAL.jar                                   tika-parsers-0.4.jar
> commons-collections-3.1.jar                      poi-3.5-beta6.jar
> jackrabbit-spi-2.0-beta3.jar                        tika-core-0.4.jar
> jackrabbit-spi-commons-1.5.5.jar
> poi-scratchpad-3.0.2-FINAL.jar
> jackrabbit-spi-commons-2.0-beta3.jar          poi-scratchpad-3.5-beta6.jar
> commons-io-1.4.jar
> jackrabbit-standalone-2.0-beta3.jar
> concurrent-1.3.4.jar                                   slf4j-api-1.5.3.jar
> derby-10.2.1.6.jar
> slf4j-log4j12-1.5.3.jar
> dom4j-1.6.1.jar
> jackrabbit-webdav-2.0-beta3.jar
> fontbox-0.1.0.jar
> jcl-over-slf4j-1.5.3.jar
> geronimo-stax-api_1.0_spec-1.0.jar            lucene-core-2.4.1.jar
> jcr-2.0-b114.jar
> xercesImpl-2.8.1.jar
> jackrabbit-api-2.0-beta3.jar                         xmlbeans-2.3.0.jar
> jackrabbit-core-2.0-beta3.jar                       xmlParserAPIs.jar
> slf4j-simple-1.3.0.jar                                  xml-apis-1.3.03.jar
>
>
> Thanks,
> simer
>
>
>
> --
> View this message in context: http://n4.nabble.com/list-of-jars-needed-for-jackrabbit-2-0-tp965852p965852.html
> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
>

Mime
View raw message