jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anand <simer.anan...@gmail.com>
Subject Repository lock
Date Thu, 10 Dec 2009 11:18:24 GMT

Hello Users,

I' m using jackrabbit1.5.6. and tried to start repository from my code.
Whenever i tried to start it using code then Repository lock comes in
between.

javax.jcr.RepositoryException: The repository home
/home/sda_tr1/Desktop/simer/apache-tomcat-6.0.20/bin/jackrabbit appears to
be already locked by the current process.

I tired to delete file .lock within jackrabbit then it was fine but from
last few hours i' m not able run repository even if i delete this .lock
file.

Some similar files are created within the versions folder and within
workspace folder(default, security) of jackrabbit.

Is there any method using which i access the repository using code without
lock?
like  isLock(), or something like that.

Thanks,
simer

-- 
View this message in context: http://n4.nabble.com/Repository-lock-tp956875p956875.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.

Mime
View raw message