jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Klimetschek <aklim...@day.com>
Subject Re: maven compile java version
Date Tue, 24 Nov 2009 08:30:37 GMT
On Mon, Nov 23, 2009 at 23:39, ChadDavis <chadmichaeldavis@gmail.com> wrote:
> Just curious, why is Jackrabbit on 1.4?

Jackrabbit 2.0 is being based on Java 1.5.

Jackrabbit 1.x was started years ago when many app servers and
enterprise customers still required 1.4 (some of them still do
today!). Since minor releases (.x) must be backwards compatible, the
change could only happen with 2.0

See also http://markmail.org/thread/j6jadbzn76cliqj6

Regards,
Alex

-- 
Alexander Klimetschek
alexander.klimetschek@day.com

Mime
View raw message