jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jukka Zitting <jukka.zitt...@gmail.com>
Subject Re: maven compile java version
Date Mon, 23 Nov 2009 21:31:01 GMT
Hi,

On Mon, Nov 23, 2009 at 10:17 PM, ChadDavis <chadmichaeldavis@gmail.com> wrote:
> In eclipse, with the m2eclipse plugin, my Jackrabbit 1.6 source won't
> compile.  It failing to recognize "assert" and other java version
> related things.  From the command line, I can build the project fine.
> But I wonder where the java version settings are?  Doesn't maven use
> Java 1.3 by default?  Where is the project defining a higher version
> of Java?  I can't find it.

See the maven-compiler-plugin configuration in parent/pom.xml.
Jackrabbit 1.x uses Java 1.4.

It may be that m2eclipse is not picking up those settings. In that
case you can manually configure your Eclipse project to use Java 1.4
or higher.

BR,

Jukka Zitting

Mime
View raw message