jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Launay <sebastienlau...@gmail.com>
Subject Re: jackrabbit issue
Date Tue, 03 Nov 2009 12:31:28 GMT
Hi,

It can also be the following issue if you are using a Jackrabbit version lower
than 1.5.5:
https://issues.apache.org/jira/browse/JCR-2057

This happens only when you start (by mistake) two repositories
using the same repository home.

2009/11/3 Alexander Klimetschek <aklimets@day.com>:
> On Tue, Nov 3, 2009 at 11:23, nanduri siva <ngsiva@gmail.com> wrote:
>> aused by: java.io.IOException: Directory was previously created with a
>> different LockFactory instance; please pass null as the lockFactory instance
>> and use setLockFactory to change it
>>       at
>> org.apache.lucene.store.FSDirectory.getDirectory(FSDirectory.java:192)
>
> Looks like the wrong Lucene version in the classpath. Jackrabbit 1.5
> needs Lucene 2.3.2, Jackrabbit 1.6 (and higher I think) needs Lucene
> 2.4.1.
>
> Regards,
> Alex

-- 
Sébastien Launay

Mime
View raw message