jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ktoro <kimmo.t...@f-secure.com>
Subject Installing JackRabbit 1.6.0 on Glassfish v2.1 disables other webapps logging
Date Thu, 26 Nov 2009 05:37:17 GMT

Hi

I tried to search for solution for this problem, but couldn't find straight
answer. 

We recently upgraded from JackRabbit 1.5.x to the 1.6.0 version. Apart from
few hickups in cluster setup we got everything working fine pretty
painlessly. A while after the upgrade we noticed that our existing web
applications were not producing _any_ log messages to Glassfish's server.log
anymore. 

JackRabbit was installed by extracting the JAR in Glassfish's
domains/domain1/lib/ext folder and jcr/repository was configured as a custom
JNDI resource on Glassfish. 

I started investigating the logging problem and eventually found that
removing jcl-over-slf4.jar from Glassfish's domain lib/ext folder solved the
problem. 

We're at the moment using Apache Commons logging for logging. 

Only libraries we have in GF's domain lib/ext are the ones included with
JackRabbit 1.6.0:
commons-collections-3.1.jar
commons-io-1.4.jar
concurrent-1.3.4.jar
jackrabbit-api-1.6.0.jar
jackrabbit-core-1.6.0.jar
jackrabbit-jca-1.6.0.jar
jackrabbit-jcr-commons-1.6.0.jar
jackrabbit-spi-1.6.0.jar
jackrabbit-spi-commons-1.6.0.jar
jackrabbit-text-extractors-1.6.0.jar
jcr-1.0.jar
log4j-1.2.14.jar
lucene-core-2.4.1.jar
slf4j-api-1.5.3.jar
slf4j-log4j12-1.5.3.jar

We have the commons logging libraries included  with our web application,
located in WEB-INF/lib:
commons-logging-1.1.1.jar
commons-logging-api-1.1.jar

Now our own logging works fine so we don't have any urgent problem. Just
would like to know what why did this happen - did we have some
misconfiguration or was the jcl-over-slf4j.jar unintentionally included with
the JackRabbit 1.6.0 distribution? 

Another thing is that I don't think we have ever got any logs from
JackRabbit itself, the following is mentioned in the server.log when
Glassfish is started:
[#|2009-11-25T16:13:10.273+0200|WARNING|sun-appserver2.1|javax.enterprise.system.stream.err|_ThreadID=18;_ThreadName=pool-1-thread-6;_RequestID=6be56db7-56ad-413e-b343-c620a5c10dda;|log4j:WARN
No appenders could be found for logger
(org.apache.jackrabbit.core.config.ConfigurationErrorHandler).|#]
[#|2009-11-25T16:13:10.276+0200|WARNING|sun-appserver2.1|javax.enterprise.system.stream.err|_ThreadID=18;_ThreadName=pool-1-thread-6;_RequestID=6be56db7-56ad-413e-b343-c620a5c10dda;|
log4j:WARN Please initialize the log4j system properly.|#]

Best Regards,

Kimmo Toro
-- 
View this message in context: http://n4.nabble.com/Installing-JackRabbit-1-6-0-on-Glassfish-v2-1-disables-other-webapps-logging-tp788040p788040.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.

Mime
View raw message