jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angela Schreiber <anch...@day.com>
Subject Re: Unable to set the policies to the node, which is under root by using 1.6 version..
Date Fri, 02 Oct 2009 06:52:44 GMT
hi

you miss some important information in your problem description.
e.g. whether you are using a custom AccessControlManager or
not... whether there is some applicable policy in the iterator
at all... whether there already exists a policy a the target
node etc. etc.

so, assuming that you are working with a default jr-core,
here is a wild guess, what could potentially explain the problem:

if i remember correctly there were still some changes made to
the jsr 283 specification at that time.

one change (though i don't remember exactly if that was between
1.5 and 1.6) was how AccessControlManager.setPolicy is expected
to work.

initially: only policies obtained through getApplicablePolicies

nowadays:  ((quote from the javadoc as follows))

       Binds the policy to the node at absPath. The behavior of the
       call acm.setPolicy(absPath, policy) differs depending on how
       the policy object was originally acquired.

       If policy was acquired through {@link #getApplicablePolicies
       acm.getApplicablePolicies(absPath)} then that policy object is
       added to the node at absPath.

       On the other hand, if policy was acquired through getPolicies
       then that policy object (usually after being altered) replaces
       its former version on the node at absPath.

hope that helps. if it's something different please
provide sufficient information that allows us to help you.

regards
angela


nsaidaiah wrote:
> We are facing issues while assigning the policies to a Node using Jackrabbit
> 1.6 version.
> 
> Please look at the attached text file. I have explained in detail.
> http://www.nabble.com/file/p25697927/Jackrabbit_issue.txt
> Jackrabbit_issue.txt 


Mime
View raw message