jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From simer anand <simer.anan...@gmail.com>
Subject Re: Implementing Jaas
Date Wed, 23 Sep 2009 06:54:43 GMT
Hello Bertrand and users,

On 9/23/09, Bertrand Delacretaz <bdelacretaz@apache.org> wrote:

> >>...                    I tried to implement the Jaas thing into
> repository and
> >> when tried the authorization tutorial programs into the repository.xml
> and
> >> when i switched to the
> >> http://localhost:8080/jackrabbit-webapp-1.5.6./repository/default/ then
> >> following thing printed out.
> >>
> >> javax.jcr.RepositoryExceptionfailed to instantiate AccessManager
> >> implementation:
> >> org.apache.jackrabbit.core.security.simple.SimpleAccessManager:
> >> sample.SampleAction cannot be cast to
> >> org.apache.jackrabbit.core.security.AccessManager...
> I don't think there's enough info here for someone to help - you'll
> need to indicate *exactly* what you did, which tutorial (URL) your
> followed, what you expected, etc.
> Describing your problem using the smallest set of precise steps that
> allows one to reproduce it gives you the best chances of getting an
> answer on this list.

 Thanks Bertrand for replying,

                                               I' m on process of
customizing the authorization into the repository and then i look at the
capability model for that but there i didn't got much as i was knew to
jackrabbit. I made authentication based on the Jaas and found it a bit
easier and i thought of trying the  jaas authorization to it. I went through
the sample programs at
and then i tried to implement it for that i put jar files into the classpath
and in repositiory.xml i placed the  class file <AccessManager class =
"sample.SampleAction"> </AccessManager>
and then i went to the
then it asked for the username and password and after submitting them it
showed something like this

javax.jcr.RepositoryExceptionfailed to instantiate
AccessManagerimplementation :
sample.SampleAction cannot be cast to


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message