jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Coelho <bruno.coe...@pmelink.pt>
Subject Re: RMI connection on tomcat 6.0
Date Fri, 18 Sep 2009 13:39:54 GMT
hi,

did you also set in the Repository servlet section of the web.xml, the  
rmi-uri?

I think you have to configure all this values in both servlets.

check in the logs if you have something like this:

18.09.2009 14:37:10 *INFO * AbstractConfig:  
---------------------------------------------- (AbstractConfig.java,  
line 108)
18.09.2009 14:37:10 *INFO * AbstractConfig: Configuration of RMIConfig  
(AbstractConfig.java, line 101)
18.09.2009 14:37:10 *INFO * AbstractConfig:  
---------------------------------------------- (AbstractConfig.java,  
line 102)
18.09.2009 14:37:10 *INFO * AbstractConfig:   rmiName: XXX.ZZZ  
(AbstractConfig.java, line 106)
18.09.2009 14:37:10 *INFO * AbstractConfig:   rmiUri: // 
123.123.123.123:1099/XXX.ZZZ (AbstractConfig.java, line 106)
18.09.2009 14:37:10 *INFO * AbstractConfig:   rmiEnabled: true  
(AbstractConfig.java, line 106)
18.09.2009 14:37:10 *INFO * AbstractConfig:   rmiPort: 1099  
(AbstractConfig.java, line 106)
18.09.2009 14:37:10 *INFO * AbstractConfig:   rmiHost: 123.123.123.123  
(AbstractConfig.java, line 106)
18.09.2009 14:37:10 *INFO * AbstractConfig:   class: class  
org.apache.jackrabbit.j2ee.RMIConfig (AbstractConfig.java, line 106)
18.09.2009 14:37:10 *INFO * AbstractConfig:   valid: true  
(AbstractConfig.java, line 106)
18.09.2009 14:37:10 *INFO * AbstractConfig:  
---------------------------------------------- (AbstractConfig.java,  
line 108)


cheers,

bruno coelho


On Sep 18, 2009, at 12:50 PM, Nedim wrote:

> Hi,
>
> hi i try this out too, i enabled rmi in bootstrab.properties and
> uncomment the three lines in web.xml for rmi-port, rmi-host and rmi- 
> uri.
>
> I set the parameter for port and host, and leave the uri default.
>
> But still i don't have results.
>
>
> Bruno Coelho wrote:
>> hi,
>>
>> you can change the port where the RMI is available.
>> go to the WEB-INF of your jackrabbit instance and edit the web.xml.
>>
>> in the RepositoryStartup servlet you can change the port that RMI  
>> will
>> use:
>>    <init-param>
>>            <param-name>rmi-port</param-name>
>>            <param-value>0</param-value>
>>            <description>
>>                The RMI port for registering the repository in the RMI
>> Registry.
>>                If equals 0, the default port is used.
>>            </description>
>>        </init-param>
>>
>> cheers,
>>
>> bruno coelho
>>
>> On Sep 17, 2009, at 4:19 PM, Nedim wrote:
>>
>>> Hi guys,
>>>
>>> I have a problem with connection to Jackrabbit over RMI. I made a  
>>> local
>>> mashine with winXP and tomcat 6.0, when I connect over RMI  
>>> everything
>>> works fine. But i my live installation is ona a Linux server with  
>>> tomcat
>>> 6.0 and the port 1099 is closed for IP addres, is only open for
>>> localhost.
>>>
>>> I try with the java.rmi.server.hostname but it doesn't work, i  
>>> have no
>>> permisions to change the /etc/hosts so is there an other way.
>>>
>>> Thx, Nedim
>>
>>
>


Mime
View raw message