jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GILBART Frederic (extérieur société ALMAVIA) <Frederic.GILB...@groupe-berri.fr>
Subject SearchIndex config and supportHighlighting changes causes NPE on search.jsp
Date Thu, 03 Sep 2009 12:10:42 GMT
Hi all,

 

After using jackrabbit for months i tryed to change my repository-workspace-SearchIndex config
using http://wiki.apache.org/jackrabbit/Search parameters, to optimize index size and queries
response times on my existing repository. 

 

I deleted all index/* and worskpaces/* folders to have index rebuilded and everything seems
ok but 1 parameter cannot be changed. 

 

First repository was using supportHighlighting=true in its workspace config - everyting was
ok.

 

When it changes to supportHighlighting=false, i cannot search anymore using the 

/jackrabbit-webapp-1.6.0/search.jsp?q=* because of :

 

org.apache.jasper.JasperException: java.lang.NullPointerException

       org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:522)

       org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:416)

       org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)

       org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)

       javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

 

cause m�re

 

java.lang.NullPointerException

       org.apache.jsp.search_jsp._jspService(search_jsp.java:265)

       org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)

       javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

       org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)

       org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)

       org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)

       javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

 

(For information, search does not produce NPE if has no results.)

 

All others parameters may change or not, only this one produce the NullPointerException

If i change it back to supportHighlighting=true and reduild indexes everything is ok again.




 

Is this a bug or do I miss some steps in such update ? Does someone notice same behavior ?
In such case, may the wiki be updated to warn of this ? 

 

Does someone know how to move from supportHighlighting=true to false because indexes are smaller
that way ? 

 

Regards,

Frederic Gilbart

 

 

 

 


Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message