jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Planamente <MikePlaname...@hotmail.com>
Subject Re: problems configuring jackrabbit indexing for full serach
Date Tue, 29 Sep 2009 14:47:24 GMT

Hi all,

problem solved, it was due to mimetype!, lucene indexation and text
extractor could not work properly with bad mimetypes set.

Michael.



Michael Planamente wrote:
> 
> Hi all,
> 
> I have some problems to configure the jackrabbit indexing in order to make
> some full search queries...
> 
> I added a searchIndex to the workspace tag and some parameters(path...) 
> but, when I try to make an xpath query like this one, nothing returns! 
> any clue? everithing seems to be correct.
> 
> //element(*,nt:resource)[jcr:contains(@jcr:data,'HTML')]   (I also tried
> '*HTML*',  '%HTML%'  and also jcr:LIKE...)
> 
> can you confirm that by default(without specifying indexingConfiguration
> param) all the properties of all nodes are indexed? 
> 
> the repository is filled with html documents... when I execute the query
> without contains(//element(*,nt:resource)) I get all resource nodes with
> data filled with my html pages!
> 
> 
> thank you,
> Michael.
> 
> 

-- 
View this message in context: http://www.nabble.com/problems-configuring-jackrabbit-indexing-for-full-serach-tp25649858p25664498.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message