jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Diephouse <dan.diepho...@mulesource.com>
Subject Wrong results from jcr:like query
Date Tue, 18 Aug 2009 21:26:47 GMT
I have a repository like with the following structure

/hello.wsdl/@name="hello.wsdl"
/hello.wsdl/1.0/@name="1.0"

I run the query:

//*[jcr:like(fn:lower-case(@name), '%hello.wsdl%')]

This turns into the Lucene query: "+1:name:%hello.wsdl%"

I'm getting back both nodes though, and not just the first one.

I tried both with my forked branch of 1.6/Lucene 2.4.2 (I know, I know....
just has JCR-977 patches in it) and also with 1.4.x/Lucene 2.2.0 which we
were on before we upgraded. I can get a more official recent version, but
does this ring a bell to anyone? I seem to recall seeing something about it
at some point.... If you give me an idea of what the modified Lucene query
should be I can probably provide a patch.

Dan
-- 
Dan Diephouse
http://mulesource.com | http://netzooid.com/blog

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message