jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From simer anand <simer.anan...@gmail.com>
Subject Re: Repository.xml configuration problem
Date Fri, 28 Aug 2009 05:28:31 GMT

Hello Alex and Users,
                                 I have this SampleAcn.java file which
instantiate the LoginContext(LC)  and then  while  instantiating the LC a
parameter is passed called "sample" and  that is the entry for jaas 
configuration file and that contains path to my LoginModule implementing
class .

Now when i execute this SampleAcn file that instantiate the LC
independently(without connected with repository) then its totally fine. And
ask for username and passwor.

Now when i used to connect with repository then i used to make this changes
in security portion of the repository.xml .
<security><LoginModule=sample.SampleAcn>
</LoginModule></security>

and sample is kept in %CATALINA_HOME's/lib directory

1. Now is it a correct way to configure the  security section of
repository.xml
2. How come Implementation of Login Module can be wrong if it is executing
independently without being connected to the repository.
3.
http://jackrabbit.apache.org/jackrabbit-configuration.html#JackrabbitConfiguration-Securityconfiguration
The above link is not feeding up to the mark.

Thank you .
-- 
View this message in context: http://www.nabble.com/Repository.xml-configuration-problem-tp25075919p25184228.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message