jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Khanapurkar, Mona A." <Mona.A.Khanapur...@idearc.com>
Subject RE: Configuring new workspace
Date Thu, 02 Jul 2009 16:17:48 GMT
Hi Alex,

Thanks for your response. I am using jackrabbit 1.3.1, but even when I switch to 1.5.6 I get
the same issue. I have attached repository.xml and the generated workspace.xml for your reference.
For security reasons, I have changed the db url, username and password from my original config

Please let me know if I've missed anything.


-----Original Message-----
From: Alexander Klimetschek [mailto:aklimets@day.com] 
Sent: Thursday, July 02, 2009 10:16 AM
To: users@jackrabbit.apache.org
Subject: Re: Configuring new workspace

On Thu, Jul 2, 2009 at 4:24 PM, Khanapurkar, Mona
A.<Mona.A.Khanapurkar@idearc.com> wrote:
>> I tried generating a new workspace programmatically using the
>> following line of code :
>> ((JackrabbitWorkspace)session.getWorkspace()).createWorkspace("my_new_
>> workspace");
>> It creates the requested workspace folder and appropriate
>> workspace.xml within it. I then try obtaining a session on the new
>> workspace like the following:
>> session = repository.login(new SimpleCredentials(username, password
>>                                               .toCharArray()),
>> "my_new_workspace");
>> It throws javax.jcr.NoSuchWorkspaceException. And the underlying error
>> is:
>> ERROR [org.apache.jackrabbit.core.fs.db.DatabaseFileSyst
>> em] - failed to initialize file system
>> com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: You have an error
>> in your S
>> QL syntax; check the manual that corresponds to your MySQL server
>> version for th
>> e right syntax to use near 'not null, FSENTRY_NAME varchar not null,
>> A varbinary null, FSENTRY_LA' at line 1

This means the database file system for the new workspace couldn't be
created, due to this SQL syntax error. This could be a
misconfiguration of the db file system, ie. the wrong implementation
or the wrong schema. What does your config look like? Are you using
the latest version of Jackrabbit (1.5.x)?


Alexander Klimetschek

View raw message