jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maxime Bégnis <max...@neodoc.biz>
Subject Re: jackrabbit and saxon6.5.5
Date Wed, 22 Jul 2009 10:54:39 GMT
Connor, Brett (LNG-TWY) a écrit :
> My guess is that saxon.jar includes some SAX parser or something that behaves differently
to the one JackRabbit is expecting when reading its configuration files. Perhaps try changing
the classpath ordering, putting saxon.jar right at the end, see if that changes anything.
>  
>
>   
Even this way, the error still happens.

I noticed another thing:
If I create the repository with a classpath that does not contain 
saxon.jar and then use the repository with the classpath containing 
saxon.jar, it works.
it seems really weird.

>> -----Original Message-----
>> From: Maxime Bégnis [mailto:maxime@neodoc.biz] 
>> Sent: 22 July 2009 10:23
>> To: users@jackrabbit.apache.org
>> Subject: jackrabbit and saxon6.5.5
>>
>> Hi,
>>
>> We are using jackrabbit 1.4 in a CMS system.
>> And we are using saxon6.5.5 for XSLT Transformation.
>> I get an exception at repository initialization.
>> I attached to this mail the java exception.
>>
>> When I remove the saxon.jar library everything works just fine.
>>
>> Did someone know about this problem?
>>
>> thanks.
>>
>> Maxime Bégnis.
>>
>>     
>
> LexisNexis is a trading name of REED ELSEVIER (UK) LIMITED - Registered office - 1-3
STRAND, LONDON WC2N 5JR
> Registered in England - Company No. 02746621
>
>   


Mime
View raw message