jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Wallace ...@rwmotloc.com>
Subject Re: Periodic sync of journal failed: Unable to return record iterater.
Date Thu, 02 Jul 2009 14:17:11 GMT
Occasionally i also get:

14:13:25,179 ERROR [org.apache.jackrabbit.core.cluster.ClusterNode:280] 
Unexpected error while syncing of journal: null
java.lang.NullPointerException
        at 
org.apache.jackrabbit.core.journal.DatabaseJournal.getRecords(DatabaseJournal.java:294)
        at 
org.apache.jackrabbit.core.journal.AbstractJournal.doSync(AbstractJournal.java:186)
        at 
org.apache.jackrabbit.core.journal.AbstractJournal.sync(AbstractJournal.java:173)
        at 
org.apache.jackrabbit.core.cluster.ClusterNode.sync(ClusterNode.java:303)
        at 
org.apache.jackrabbit.core.cluster.ClusterNode.run(ClusterNode.java:274)
        at java.lang.Thread.run(Thread.java:637)
 
Like 20 of the errors listed on the subject, and one of these.

Alexander Wallace wrote:
> Hi all...
>
> I am running a pretty much inefficiently operation but I have not a 
> lot of choice, the operation is coded like that in a package I can't 
> modify for complex reasons.
>
> Anyways, the operation pretty much:
>
> 1 - creates a jackrabbit session
> 2 - tries to retrieve a document
> 3 l logs out of the session
>
> It is done in a loop to determine if i can find the documents and make 
> sure that another part of the app that has the document registered, 
> can find the corresponding document.
>
> While doing it, i get a lot of the following:
>
> [org.apache.jackrabbit.core.cluster.ClusterNode:277] Periodic sync of 
> journal failed: Unable to return record iterater.
>
> I was also running out of db connections while running this, but I 
> upped the max-connections setting in MySql and I don't get it any 
> more...  The loop runs this 300 times, but I have 1000 connections, so 
> I don't run out of them. Something was not releasing the connections 
> in time in Jackrabbit...     This problem gone, I still get the above 
> one every time i runn the loop...  I know the connections are not idle o
>
> I am running Jackrabbit 1.4
>
>
> Any clues as to why this is happenning?, how to prevent it? Does it 
> have any impact?
>
>
>

Mime
View raw message