jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Härtel <er...@web.de>
Subject Re: workspace generation
Date Fri, 19 Jun 2009 08:45:29 GMT
No suggestions?
Additional information needed?

Eric Härtel schrieb:
> Hello list,
>
> I have a problem with the worspaces in our webapplication. when I 
> start the JBoss I get the following error message:
>
> 09:06:04,125 WARN  [ServiceController] Problem starting service 
> jboss.jca:service=ConnectionFactoryBinding,name=jcr-client/remote
> org.jboss.deployment.DeploymentException: Could not create 
> ConnectionFactory for adapter: 
> jboss.jca:service=TxCM,name=jcr-client/remote; - nested throwable: 
> (javax.resource.ResourceException: Failed to create session: 
> Replacement not found for ${wsp.name}.)
>    at 
> org.jboss.resource.connectionmanager.ConnectionFactoryBindingService.createConnectionFactory(ConnectionFactoryBindingService.java:132)

>
>    at 
> org.jboss.resource.connectionmanager.ConnectionFactoryBindingService.startService(ConnectionFactoryBindingService.java:65)

>
>    at 
> org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:289)

>
>    at 
> org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMBeanSupport.java:245)

>
>    at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
>    at 
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

>
>    at java.lang.reflect.Method.invoke(Method.java:597)
>
> In my repository.xml I have the following workspace configuration:
>
> <Workspaces rootPath="${rep.home}/workspaces"   
> defaultWorkspace="default" />
> <Workspace name="${wsp.name}">
>    <FileSystem 
> class="org.apache.jackrabbit.core.fs.local.LocalFileSystem">
>        <param name="path" value="${wsp.home}"/>
>    </FileSystem>
>    <PersistenceManager 
> class="org.apache.jackrabbit.core.persistence.bundle.PostgreSQLPersistenceManager">

>
>        <param name="driver" value="javax.naming.InitialContext"/>
>        <param name="url" value="java:client"/>
>        <param name="schemaObjectPrefix" value="${wsp.name}_" />
>    </PersistenceManager>
>    <SearchIndex   
> class="org.apache.jackrabbit.core.query.lucene.SearchIndex">
>        <param name="path" value="${wsp.home}/index" />
>        <param name="textFilterClasses" 
> value="org.apache.jackrabbit.extractor.MsWordTextExtractor,org.apache.jackrabbit.extractor.MsExcelTextExtractor,org.apache.jackrabbit.extractor.MsPowerPointTextExtractor,org.apache.jackrabbit.extractor.PdfTextExtractor,org.apache.jackrabbit.extractor.OpenOfficeTextExtractor,org.apache.jackrabbit.extractor.RTFTextExtractor,com.sprylab.textextractor.HTMLTextExtractor,org.apache.jackrabbit.extractor.XMLTextExtractor,org.apache.jackrabbit.extractor.PlainTextExtractor"

> />
>        <param name="extractorPoolSize " value="2" />
>        <param name="supportHighlighting" value="true" />
>        <param name="analyzer" 
> value="com.sprylab.phonetix.PhoneticAnalyzer" />
>        <param name="indexingConfiguration" 
> value="${rep.home}/indexing_configuration.xml" />
>        <param name="respectDocumentOrder" value="false"/>
>    </SearchIndex>
> </Workspace>
>
> I would expect that beside the repository.xml a directory 'workspaces' 
> with on directory per workspace (at least 'default') and the 
> appropriate workspace.xml is created. But it doesn't happen :-( Can 
> anybody give me an hint what goes wrong here.
>
> BTW, I did upgrade from version 1.4.4 to 1.5.5.  Could it be the 
> configuration has changed or so?
>
>

Mime
View raw message