jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From neman ould sidahmed <nould...@yahoo.fr>
Subject [SOLVED] Re: custom indexing for jackrabbit
Date Thu, 14 May 2009 14:38:49 GMT
Hello everyone, 


my problem was the in cusom configuration file, I had indexed the property mynamespace:title
missed in the configuration file.

Thank's

regards

Neman.
--- En date de : Mer 4.3.09, Marcel Reutegger <marcel.reutegger@gmx.net> a écrit :

De: Marcel Reutegger <marcel.reutegger@gmx.net>
Objet: Re: custom indexing for jackrabbit
À: users@jackrabbit.apache.org
Date: Mercredi 4 Mars 2009, 10h35

Hi,

On Mon, Mar 2, 2009 at 13:56, neman ould sidahmed <nouldsid@yahoo.fr> wrote:
> I get my item with the quer
>
> "select *  from mynamespace:item where mynamespace:title = 'nould' "
> the title is unique.
>
> ok, I get my item, I update for example the title for this item and I save the session,
the new
>  value of title is 'nould1'.
>
> I do the same query, with new tilte,  the new query is :
> "select *  from mynamespace:item where mynamespace:title = 'nould1' "
> the query for that item does not return anymore?
>
> If I check with XPath qury, I got the item. I think the problem is the re-index of this
item.

Whether you use SQL or XPath is just a syntactical difference but does
not change the way how items are indexed or queried. If it works with
XPath, then something must be wrong with your SQL statement.

regards
 marcel



      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message