jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Klimetschek <aklim...@day.com>
Subject Re: ItemStateException with some drivers
Date Tue, 14 Apr 2009 15:49:18 GMT
On Tue, Apr 14, 2009 at 5:36 PM, SalmasCM <salmas@criticalmass.com> wrote:
> Would it be possible to get some documentation about which version of the
> JDBC spec Jackrabbit is compatible with. it looks like its version 1.2 and
> above? Our SQL group wants to know the version so that they can make sure to
> be compliant.

1.2 and above is probably right, but I don't know it for sure. Anyone?

> Also, does there exist somewhere a list of jars for each version of JR? I'd
> like to know which versions I should have for the latest JR release. It
> looks like 1.4.9 is the latest release of the core jar and this goes with JR
> version 1.5.4?

No, the latest core jar is also named 1.5.4. (With minor versions, eg.
1.x, we always increase all version numbers for the various
jackrabbit-* jars, but for patch releases, eg. 1.5.x, only the
actually modified jars increase. The jackrabbit-core jar, however,
changes in most releases anyway)

To get a list of the required jars and their version number, you can
always look at the webapp distribution of the JR release you are
using. Download it from http://jackrabbit.apache.org/downloads.html ,
and look into WEB-INF/lib. The list for 1.5.4 is:

commons-codec-1.2.jar
commons-collections-3.1.jar
commons-httpclient-3.0.jar
commons-io-1.4.jar
concurrent-1.3.4.jar
derby-10.2.1.6.jar
fontbox-0.1.0.jar
jackrabbit-api-1.5.0.jar
jackrabbit-core-1.5.4.jar
jackrabbit-jcr-commons-1.5.3.jar
jackrabbit-jcr-rmi-1.5.0.jar
jackrabbit-jcr-server-1.5.2.jar
jackrabbit-jcr-servlet-1.5.2.jar
jackrabbit-spi-1.5.0.jar
jackrabbit-spi-commons-1.5.0.jar
jackrabbit-text-extractors-1.5.0.jar
jackrabbit-webdav-1.5.2.jar
jcl-over-slf4j-1.5.3.jar
jempbox-0.2.0.jar
log4j-1.2.14.jar
lucene-core-2.3.2.jar
nekohtml-1.9.7.jar
pdfbox-0.7.3.jar
poi-3.0.2-FINAL.jar
poi-scratchpad-3.0.2-FINAL.jar
slf4j-api-1.5.3.jar
slf4j-log4j12-1.5.3.jar
xercesImpl-2.8.1.jar
xml-apis-1.3.03.jar


Regards,
Alex

-- 
Alexander Klimetschek
alexander.klimetschek@day.com

Mime
View raw message