jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Guggisberg <stefan.guggisb...@gmail.com>
Subject Re: NullPointer in JackRabbit InternalValue class
Date Thu, 09 Apr 2009 14:15:13 GMT
On Thu, Apr 9, 2009 at 3:18 PM, Kooper <sergeysachkov@list.ru> wrote:
>
>
>
> Stefan Guggisberg wrote:
>>
>> i quickly tried to reproduce the issue using your instructions.
>> everything worked as expected, i.e. i was unable to reproduce it.
>> please feel free to post a jira issue and attach a simple test case
>> including a custom node type def.
>>
>> cheers
>> stefan
>>
>>>
>>> Thanks for reply.
>>> --
>>> View this message in context:
>>> http://www.nabble.com/NullPointer-in-JackRabbit-InternalValue-class-tp22870428p22910237.html
>>> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
>>>
>>>
>>
>>
> Hi,
> I've posted improvement to jira. I've got into more details and found out
> that there is possibility to set null into propertyDefinition and this leads
> to null pointer inside JackRabbit. I understand that setting null is against
> JCR spec, but my thought is if there exists slight possobility of null
> pointer it should be checked.

thanks for posting the issue [1]. i think it's a bug. it might be specific to
jcr-rmi since i wasn't able to reproduce it with a local jackrabbit instance.

cheers
stefan

[1] http://issues.apache.org/jira/browse/JCR-2068

>
> Thanks for your reply.
> --
> View this message in context: http://www.nabble.com/NullPointer-in-JackRabbit-InternalValue-class-tp22870428p22970799.html
> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
>
>

Mime
View raw message