jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torgeir Veimo <torg...@pobox.com>
Subject index format error w JR 1.4.6
Date Wed, 22 Apr 2009 05:56:28 GMT
Am getting this exception on one of our deployments;

07:49:36,007 ERROR RepositoryImpl  - Failed to initialize workspace  
'default'
javax.jcr.RepositoryException: Unknown format version: -4: Unknown  
format version: -4: Unknown format version: -4
	at  
org 
.apache 
.jackrabbit 
.core.SearchManager.initializeQueryHandler(SearchManager.java:584)
	at org.apache.jackrabbit.core.SearchManager.<init>(SearchManager.java: 
264)
	at org.apache.jackrabbit.core.RepositoryImpl 
$WorkspaceInfo.getSearchManager(RepositoryImpl.java:1613)
	at  
org 
.apache 
.jackrabbit.core.RepositoryImpl.initWorkspace(RepositoryImpl.java:606)
	at  
org 
.apache 
.jackrabbit 
.core.RepositoryImpl.initStartupWorkspaces(RepositoryImpl.java:415)
	at  
org.apache.jackrabbit.core.RepositoryImpl.<init>(RepositoryImpl.java: 
305)
	at  
org.apache.jackrabbit.core.RepositoryImpl.create(RepositoryImpl.java: 
557)
	at org.apache.jackrabbit.core.TransientRepository 
$1.getRepository(TransientRepository.java:186)
	at  
org 
.apache 
.jackrabbit 
.core.TransientRepository.startRepository(TransientRepository.java:265)
	at  
org 
.apache 
.jackrabbit.core.TransientRepository.login(TransientRepository.java:333)
	at  
org 
.apache 
.jackrabbit.core.TransientRepository.login(TransientRepository.java:363)

Am suspecting the admin might have deployed a version of our product  
that uses JR 1.5.* thus auto upgrading the lucene indexes, then  
reverted back to the one based on 1.4.6. Can this be the case, or are  
the indexes most likely hosed? I think I remember the exeption being  
different in the case of wrong lucene format from previous messages to  
this list.

Is there an easy way to fix this?

-- 
Torgeir Veimo
torgeir@pobox.com





Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message