jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chakra <chakri.tut...@gmail.com>
Subject Re: Jackrabbit + JDBC with JTA
Date Sat, 28 Mar 2009 22:26:18 GMT

Hi Sergey,
Did find any solution to the problem you mentioned. I am also stuck at the
same point.
I am also trying use ATOMIKOS with Jackrabbit.

I tried by commenting connectionManager in repository bean. But XA
transactions are not working.

I also tried to use JcaTransactionalResource as follows

<bean id="jackRabbit"
class="com.atomikos.datasource.xa.jca.JcaTransactionalResource">
		<constructor-arg index="0" value="jcr170" />
		<constructor-arg index="1" ref="repositoryManagedConnectionFactory" />
	</bean>

but I am not sure how to get a connectionManager from this.

If you find any solution, please let me know. It will be really helpful for
me.

Chakra
-- 
View this message in context: http://www.nabble.com/Jackrabbit-%2B-JDBC-with-JTA-tp22602528p22762071.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message