jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SalmasCM <sal...@criticalmass.com>
Subject Re: Exception retrieving Node with UUID - please help
Date Mon, 16 Mar 2009 19:39:40 GMT

It seems that I have these issues regardless of which workspace I am using so
merging and cloning are not the issue. The cluster indexes are corrupted or
incomplete. They look ok. The redo log for the second node is 19k and zero
for node 1 and node 1 workspace index folders have different names with a
"1" appended so _1b on node 1 and _t on node 2. There is one more folder in
repository\workspaces\default\index than in
repository\workspaces\default\index for node 1. node 1 works fine but I
can't search for anything in node2.

My cluster def looks like:

    &lt;Cluster id="node1"&gt;
  	&lt;Journal
class="org.apache.jackrabbit.core.journal.MSSqlDatabaseJournal"&gt;
    &lt;param name="revision" value="${rep.home}/revision.log" /&gt;
    &lt;param name="driver"
value="com.microsoft.sqlserver.jdbc.SQLServerDriver" /&gt;
    &lt;param name="url"
value="jdbc:sqlserver://localhost:1433;databaseName=MY_DB" /&gt;
    &lt;param name="user" value="My_USER"/&gt;
    &lt;param name="password" value="MY_PASSWORD"/&gt;
  &lt;/Journal&gt;
&lt;/Cluster&gt;

I've deleted my repository and workspace folders and dropped and recreated
the entire database but I have the same issues. 

WARN org.apache.jackrabbit.core.query.lucene.DocOrderNodeIteratorImpl - Node
54d47f9e-0966-4ec1-9195-94932bdf0284 does not exist anymore:
javax.jcr.ItemNotFoundException: 54d47f9e-0966-4ec1-9195-94932bdf0284
 WARN org.apache.jackrabbit.core.query.lucene.DocOrderNodeIteratorImpl -
Node c7def115-1125-4a8a-924d-9b51d4a01a8f does not exist anymore:
javax.jcr.ItemNotFoundException: c7def115-1125-4a8a-924d-9b51d4a01a8f
WARN org.apache.jackrabbit.core.query.lucene.DocOrderNodeIteratorImpl - Node
a0b714ae-14f8-4d3c-b03f-aff8efe22c5a does not exist anymore:
javax.jcr.ItemNotFoundException: a0b714ae-14f8-4d3c-b03f-aff8efe22c5a
WARN org.apache.jackrabbit.core.query.lucene.DocOrderNodeIteratorImpl - Node
f35325c6-e2d8-447e-83e6-e995be8305d2 does not exist anymore:
javax.jcr.ItemNotFoundException: f35325c6-e2d8-447e-83e6-e995be8305d2
3235 [ExecuteThread: '14' for queue: 'weblogic.kernel.Default'] WARN
org.apache.jackrabbit.core.query.lucene.DocOrderNodeIteratorImpl - Node
ed194b79-70f9-4122-bd91-1da1750c88ba does not exist anymore:
javax.jcr.ItemNotFoundException: ed194b79-70f9-4122-bd91-1da1750c88ba
WARN org.apache.jackrabbit.core.query.lucene.DocOrderNodeIteratorImpl - Node
7742c016-5c25-40a9-9f9e-5f713f63a387 does not exist anymore:
javax.jcr.ItemNotFoundException: 7742c016-5c25-40a9-9f9e-5f713f63a387
WARN org.apache.jackrabbit.core.query.lucene.DocOrderNodeIteratorImpl - Node
59676e8e-3a90-4314-b8f8-a5a36307ce93 does not exist anymore:
javax.jcr.ItemNotFoundException: 59676e8e-3a90-4314-b8f8-a5a36307ce93


I am importing the data using the XML import feature and I do store some
image content. Not sure why the indexes seem to be corrupted. Any help would
really be appreciated.


SalmasCM wrote:
> 
> I am using JR 1.5. I have a clustered server connecting to a MSSQL db with
> a node with a default workspace and another node with a default and
> preview workspace. I used the XML import facilities to load my data into
> the default workspace of the first node. When I start the second node I
> create the preview workspace. I then merge the data from the default to
> the preview workspace in that node. When I try an XPATH query within the
> preview space in the second node I get the following error when I ask the
> query result for its nodes.
> 
> Exception retrieving Node with UUID: 73fd99b6-551d-4922-b255-e31cd3fe59e4:
> javax.jcr.ItemNotFoundException: 73fd99b6-551d-4922-b255-e31cd3fe59e4
> 
> I've tried deleting my lucene indexes but I still get the same error. Any
> help will be much appreciated.
> 
> Thanks!
> 

-- 
View this message in context: http://www.nabble.com/Exception-retrieving-Node-with-UUID---please-help-tp22531221p22543113.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message