jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From neman ould sidahmed <nould...@yahoo.fr>
Subject Re: custom indexing for jackrabbit
Date Mon, 02 Mar 2009 11:52:33 GMT
Hi, 
tank for your response, 

but, the SearchIndex element from the
workspace.xml is exactly the SearchIndex element from the repository.xml.

The problem is if I update my item, I lose the item, why?

if I re-index the data without indexconfiguration, I got my item, 
I update the item, I got it whitout problem.

I think the problem is the file jackrabbit-indexing.xml, but it's like 
the conf in the wiki!!!

I hope it's clear.


The searchIndex element in workspace.xml :
        <!-- Search index and the file system it uses.

            class: FQN of class implementing the QueryHandler interface -->

        <SearchIndex class="org.apache.jackrabbit.core.query.lucene.SearchIndex">

            <param name="path" value="${wsp.home}/index"/>

            <param name="indexingConfiguration" value="${rep.home}/jackrabbit-indexing.xml"/>

            <param name="textFilterClasses"
value="org.apache.jackrabbit.extractor.MsWordTextExtractor,org.apache.jackrabbit.extractor.MsExcelTextExtractor,org.apache.jackrabbit.extractor.MsPowerPointTextExtractor,org.apache.jackrabbit.extractor.PdfTextExtractor,org.apache.jackrabbit.extractor.OpenOfficeTextExtractor,org.apache.jackrabbit.extractor.RTFTextExtractor,org.apache.jackrabbit.extractor.HTMLTextExtractor,org.apache.jackrabbit.extractor.XMLTextExtractor"/>

            <param name="extractorPoolSize " value="2"/>

            <param name="supportHighlighting" value="true"/>

            <param name="forceConsistencyCheck" value="false"/>

            <param name="enableConsistencyCheck" value="false"/>

        </SearchIndex>

regards 

nould
--- En date de : Lun 2.3.09, Marcel Reutegger <marcel.reutegger@gmx.net> a écrit :
De: Marcel Reutegger <marcel.reutegger@gmx.net>
Objet: Re: custom indexing for jackrabbit
À: users@jackrabbit.apache.org
Date: Lundi 2 Mars 2009, 12h01

Hi,

On Mon, Mar 2, 2009 at 11:08, neman ould sidahmed <nouldsid@yahoo.fr>
wrote:
> <SearchIndex
class="org.apache.jackrabbit.core.query.lucene.SearchIndex">
>     <param name="path"
value="${rep.home}/repository/index"/>
>     <param name="indexingConfiguration"
value="${rep.home}/jackrabbit-indexing.xml"/>
>     <param name="textFilterClasses"
value="org.apache.jackrabbit.extractor.MsWordTextExtractor,org.apache.jackrabbit.extractor.MsExcelTextExtractor,org.apache.jackrabbit.extractor.MsPowerPointTextExtractor,org.apache.jackrabbit.extractor.PdfTextExtractor,org.apache.jackrabbit.extractor.OpenOfficeTextExtractor,org.apache.jackrabbit.extractor.RTFTextExtractor,org.apache.jackrabbit.extractor.HTMLTextExtractor,org.apache.jackrabbit.extractor.XMLTextExtractor"/>
>     <param name="extractorPoolSize "
value="2"/>
>     <param name="supportHighlighting"
value="true"/>
>     <param name="forceConsistencyCheck"
value="false"/>
>     <param name="enableConsistencyCheck"
value="false"/>
> </SearchIndex>

this looks like the SearchIndex element for the version store in the
repository.xml. Did you change the workspace.xml files accordingly as
well? If you did, please post the SearchIndex element from the
workspace.xml.

furthermore, what's the exact error you see?

regards
 marcel



      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message