jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shailesh Mangal <shailesh.man...@getzephyr.com>
Subject Re: Migrate from 1.3 to 1.3.4 and move data from windows to linux
Date Tue, 03 Feb 2009 18:21:28 GMT

On Feb 3, 2009, at 10:08 AM, Alexander Klimetschek wrote:

> On Tue, Feb 3, 2009 at 6:36 PM, Shailesh Mangal
> <shailesh.mangal@getzephyr.com> wrote:
>> I noticed that everything (including workspace.xml) gets recreated  
>> (on mac
>> and windows). I am witnessing this issue on Linux (Fedora) that the  
>> indexing
>> are not getting rebuilt.
>
> Are you sure workspace.xml gets re-created properly (ie. compare old
> and new workspace.xml)?

Yes, we only have default workplace.
>
>
> I assume you only have the "default" workspace that gets automatically
> created on startup and copies the template values from the workspace
> section in repository.xml, that are probably the same for your only
> workspace, and once the workspace's persistence manager starts and
> connects to the DB, it (coincidentally) detects the data that is
> already existing. This approach would definitely fail as soon as you
> would have two slightly differently configured workspaces...
>
>> BTW, I have also tried deleting just the indexes, same behavior.
>
> Can you access the nodes and properties, are they present? The index
> is not required for navigational access, only for search operations.
> And do you see anything in the logs?

Nothing in logs. Can't access nodes and properties. My datafile export  
size is 105MB and data shows up fine in xp.

>
>
> Regards,
> Alex
>
> -- 
> Alexander Klimetschek
> alexander.klimetschek@day.com

Mime
View raw message