jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject Re: Jackrabbit 1.4 building matters
Date Tue, 13 Jan 2009 16:03:40 GMT
Hi,

On Tue, Jan 13, 2009 at 1:57 PM, Gaetano Sferra <gsferra@imnet.it> wrote:
> Jukka Zitting ha scritto:
>> Jackrabbit 1.4 should work just fine with Java 1.5. What's the problem
>> you were seeing?
>
> I get this exception (source/binary version JDK 5 and JRE 1.5):
>
> Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad
> version number in .class file
> [...]
>       at
> org.apache.jackrabbit.core.TransientRepository.class$(TransientRepository.java:56)

This line is loading the SLF4J LoggerFactory. What SLF4J
implementation are you using? I believe the LoggerFactory class you
have in your classpath is compiled only for Java 6.

BR,

Jukka Zitting

Mime
View raw message