jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject Re: 1.5 upgrade problem
Date Wed, 10 Dec 2008 21:16:55 GMT
Hi,

On Wed, Dec 10, 2008 at 9:31 PM, Jim Jones <jones@trivantisdev.com> wrote:
> I'm trying to upgrade to 1.5 and am getting the following exception when I
> try to startup the repository.  I removed the <!DOCTYPE> setting per the
> release notes.  Is this related to JCR-1462?

Yes, Jackrabbit 1.5 is being more careful about incorrect
configuration files. Jackrabbit 1.4 would just ignore all options it
didn't recognize, but 1.5 will fail with an error so that you don't
accidentally leave typos or other mistakes in your configurations.

> 301266 [main] ERROR org.apache.jackrabbit.core.RepositoryImpl - failed to
> start Repository: org.apache.jackrabbit.core.data.db.DbDataStore does not
> support 'schema

Check your <DataStore> configuration. It looks like you have a <param
name="schema" value="..."/> entry there. There's no "schema" parameter
for the DbDataStore, and never has been. You're probably looking for
the "databaseType" parameter (I know, we're not very consistent...).

BR,

Jukka Zitting

Mime
View raw message