jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject Re: Is database migration necessary between 1.4 and 1.5 version ?
Date Tue, 09 Dec 2008 10:43:01 GMT
Hi,

On Tue, Dec 9, 2008 at 11:34 AM, BOUCHET Jean-Luc
<jean-luc.bouchet@sib.fr> wrote:
> My question concerns database scheme compatibility : will database migration
> be necessary between 1.4 and 1.5 version?

No. Jackrabbit 1.5 should be fully backwards compatible with your
existing repositories and repository configuration files.

Our general policy is to maintain full backwards compatibility within
major release cycles, i.e. all 1.x releases should be compatible with
all versions down to 1.0.

> What about future version (2.0...)?

We may break backwards compatibility when upgrading to a new major
release like 2.0 and 3.0, but I would expect us to provide the
required upgrade instructions and migration tools for any required
changes.

BR,

Jukka Zitting

Mime
View raw message