jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fran Diaz" <frandia...@gmail.com>
Subject Jackrabbit Security Authentication Policy
Date Tue, 23 Dec 2008 13:04:08 GMT
Hello. I'm trying to deploy Jackrabbit 1.5.0 via JCA resource adapter in
JBoss 4.2.3. I don't want any access control to the repository, therefore I
just left the default security config in the repository.xml as follows:

    <Security appName="Jackrabbit">
        <SecurityManager
class="org.apache.jackrabbit.core.security.simple.SimpleSecurityManager"
workspaceName="security">
        </SecurityManager>
        <AccessManager
class="org.apache.jackrabbit.core.security.simple.SimpleAccessManager">
        </AccessManager>
        <LoginModule
class="org.apache.jackrabbit.core.security.simple.SimpleLoginModule">
           <param name="anonymousId" value="anonymous"/>
           <param name="adminId" value="admin"/>
        </LoginModule>
    </Security>

The problem is that Jackrabbit ignores it and is using instead the
UsersRolesLoginModule, that is, the JBoss default JAAS authentication.

Maybe I'm doing something wrong. Can anybody help me please?

I have another question. If I have three workspaces, do I have to write both
three <SecurityManager> declarations for each workspace?. For example:

<SecurityManager
class="org.apache.jackrabbit.core.security.simple.SimpleSecurityManager"
workspaceName="workspace1"/>
<SecurityManager
class="org.apache.jackrabbit.core.security.simple.SimpleSecurityManager"
workspaceName="workspace2"/>
<SecurityManager
class="org.apache.jackrabbit.core.security.simple.SimpleSecurityManager"
workspaceName="workspace3"/>

Best regards.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message