jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Klimetschek" <aklim...@day.com>
Subject Re: How to see repository nodes in JCR browser?
Date Wed, 12 Nov 2008 22:21:34 GMT
If you connect to a running repository, you have to do that via RMI.
IIRC the JCR browser plugin has two ways to connect, local or remote.

The reason is that only one Jackrabbit instance can access the
directory with all the data (typically named repository/), thus there
is a lock file present that prevents a second Jackrabbit instance
configured with the same directory to overwrite the files. For a
scenario where multiple JCR clients in different VMs have to access
the same repository, RMI is the standard way to go.

Regards,
Alex

On Wed, Nov 12, 2008 at 9:41 PM, Fard <maurice.fard@gmail.com> wrote:
>
> Hello there,
>
> I have down loaded "5minutes" and "Beans_and_collections" programs , the
> tutorials of "Object Content Mapping". I ran both of them in eclipse and
> both of them work well. I tried to see the created node/s in repository by
> JCR Browser, but I got the error "It was not possible to log in. Please
> check the credentials."
> In detail "Directory was previously created with a different lockFactory
> instance, please pass null as the lockFactory instance and use
> setLockFactory to change it.
>
> I appreciate for any help, beacuse I don't know how.
>
>
> Regards
> Maurice
> --
> View this message in context: http://www.nabble.com/How-to-see-repository-nodes-in-JCR-browser--tp20468890p20468890.html
> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
>
>



-- 
Alexander Klimetschek
alexander.klimetschek@day.com

Mime
View raw message