jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Reutegger <marcel.reuteg...@gmx.net>
Subject Re: 1.4.6 including lucene 2.3.2 fix 696653?
Date Mon, 24 Nov 2008 09:02:49 GMT
Torgeir Veimo wrote:
> I just tried jackrabbit 1.4.5 with lucene 2.3.2 and it fails with the
> 
> org.apache.lucene.store.AlreadyClosedException: this IndexReader is closed
> 
> exception. According to https://issues.apache.org/jira/browse/JCR-1363
> this was fixed in commit 696653. Is that commit not part of jr 1.4.6?

no, it is not. see the 'fix versions' in JCR-1363.

> It doesn't seem to be according to my limited testing.
> 
> Also, is jr 1.4.6 and 1.5.0pre both supposed to work with lucene 2.4.0?

2.4.0 will definitively not work with jackrabbit 1.4.6. I quickly ran the unit
tests on jackrabbit-core trunk with lucene 2.4.0 and all tests ran successfully,
however there are some assertion errors the were thrown in lucene. I guess this
indicates that there is some work that needs to be done first before we can use
2.4.0.

regards
 marcel

Mime
View raw message