jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Müller" <thomas.muel...@day.com>
Subject Re: WebDAV connector
Date Thu, 09 Oct 2008 13:57:38 GMT
Hi,

kill -QUIT <pid> should give you a full thread dump. Maybe the thread
dump is in the log file only. If that doesn't work then try:

jstack -l <pid>

This requires JDK 1.6.

Regards,
Thomas


On Thu, Oct 9, 2008 at 3:53 PM, Cédric Chantepie <cchantepie@corsaire.fr> wrote:
> Jukka Zitting a écrit :
>>
>> Hi,
>>  OK, then there must be some other issue.
>>  Can you try profiling the repository server? Add something like the
>> following to the java command line:
>>
>>    -agentlib:hprof=cpu=samples,depth=30
>>
>> This will produce a java.hprof.txt file in the current directory. This
>> file shows what's taking up most time in the repository server. You'll
>> want to start the server java process just before you start your test
>> clients and close the server once the test is done.
>>
>> BR,
>>
>> Jukka Zitting
>>
>
> To continue from my previous post, I've tried testing again with sun jdk 1.6
> and -agentlib:hprof=cpu=samples,depth=30 but few times after I tried it
> freezed again. It is probably related with document merging as last output I
> can get is "[IndexMerger] merged 543 documents in 7997 ms into _a.", then
> nothing happen in JBoss.
>
> I've let JBoss starting quietly, double-checking it uses proper JVM, it
> takes 2m:35s:135ms. Then wait some times so the test server get down to an
> average load (uptime give me 0.47, 1.11, 0.85). I start testing, it transfer
> some file over the 128 total (about 4 or 5% of files I think) and then
> freezed (I last thing I get see in JBoss trace is message from IndexMerger).
>
> I could try test with blackdown JVM but I think the trouble would be the
> same.
> Maybe some mutex trouble about merging ?
>
> Cédric
>
>
>

Mime
View raw message