jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Warner Onstine <wonst...@vmsinfo.com>
Subject clustering doesn't appear to be
Date Mon, 29 Sep 2008 21:13:39 GMT
I really am not sure what is going on here as things appear to be  
working (according to the logs), but unfortunately I can't see stuff  
from one node to a different node.

I have two machines setup, each with their own nodes. They are both  
connecting to the same db, and when I fired up the second node  
everything seemed fine as the second node synced up with the first one.

I then decided to mount this node (2) (I'm using WebDAV for my  
interface so I'm mounting it that way). I pushed up some new files and  
in the log files of both nodes I can see them syncing with each other.

Node 2:
2008-09-29 17:03:18,200 INFO  [ClusterNode] Appended revision: 1918
2008-09-29 17:03:18,592 INFO  [ClusterNode] Appended revision: 1919
2008-09-29 17:03:18,939 INFO  [ClusterNode] Appended revision: 1920
2008-09-29 17:03:23,230 INFO  [ClusterNode] Appended revision: 1923
2008-09-29 17:03:23,681 INFO  [ClusterNode] Appended revision: 1924
2008-09-29 17:03:24,017 INFO  [ClusterNode] Appended revision: 1925


Node 1:
2008-09-29 17:03:22,464 INFO  [AbstractJournal] Record with revision  
'1917' created by this journal, skipped.
2008-09-29 17:03:22,464 INFO  [AbstractJournal] Record with revision  
'1918' created by this journal, skipped.
2008-09-29 17:03:22,464 INFO  [AbstractJournal] Record with revision  
'1919' created by this journal, skipped.
2008-09-29 17:03:22,465 INFO  [AbstractJournal] Record with revision  
'1920' created by this journal, skipped.
2008-09-29 17:03:22,465 INFO  [AbstractJournal] Record with revision  
'1921' created by this journal, skipped.
2008-09-29 17:03:22,466 INFO  [AbstractJournal] Synchronized to  
revision: 1921
2008-09-29 17:03:27,471 INFO  [AbstractJournal] Record with revision  
'1922' created by this journal, skipped.
2008-09-29 17:03:27,471 INFO  [AbstractJournal] Record with revision  
'1923' created by this journal, skipped.
2008-09-29 17:03:27,471 INFO  [AbstractJournal] Record with revision  
'1924' created by this journal, skipped.
2008-09-29 17:03:27,472 INFO  [AbstractJournal] Record with revision  
'1925' created by this journal, skipped.
2008-09-29 17:03:27,472 INFO  [AbstractJournal] Record with revision  
'1926' created by this journal, skipped.
2008-09-29 17:03:27,473 INFO  [AbstractJournal] Synchronized to  
revision: 1926

But when I look at these two nodes separately one has the new content  
and one doesn't. Curious, I added new content to node 1 and the same  
behavior comes up where I can see the new content I just put up on  
node 1, but not on node 2.

Any ideas? This seems to be very odd behavior and I'm not sure if it  
has something to do with WebDAV or not.

-warner

Mime
View raw message