jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Harris" <michael.e.har...@gmail.com>
Subject Re: Repository startup error
Date Sun, 21 Sep 2008 00:19:56 GMT
looks like you don't have the required jars on your classpath....make sure
every required jackrabbit jar is there.

On Sat, Sep 20, 2008 at 8:09 PM, xing007008 <xing007008@163.com> wrote:

>
> I Got the same error, and I used the version  lucene-core-2.2.0.jar and
> jackrabbit-core-1.4.jar.
> How should I do to fix the error.
>
>
> AdamR wrote:
> >
> > Hi there,
> >
> > Quick question from a Jackrabbit novice. I'm attempting to run Jackrabbit
> > from Spring using spring-modules-jcr, and I've yet to get the repository
> > to start properly.
> >
> > Any thoughts on my latest NoSuchMethodError?
> >
> > Cheers,
> > Adam
> >
> > ERROR ContextLoader - Context initialization failed
> > org.springframework.beans.factory.BeanCreationException: Error creating
> > bean with name 'repository' defined in class path resource
> > [applicationContext.xml]: Invocation of init method failed; nested
> > exception is java.lang.NoSuchMethodError:
> >
> org.apache.jackrabbit.core.nodetype.NodeTypeRegistry.getEffectiveNodeType(Lorg/apache/jackrabbit/spi/Name;)Lorg/apache/jackrabbit/core/nodetype/EffectiveNodeType;
> > Caused by:
> > java.lang.NoSuchMethodError:
> >
> org.apache.jackrabbit.core.nodetype.NodeTypeRegistry.getEffectiveNodeType(Lorg/apache/jackrabbit/spi/Name;)Lorg/
> > apache/jackrabbit/core/nodetype/EffectiveNodeType;
> >         at
> >
> org.apache.jackrabbit.core.persistence.bundle.AbstractBundlePersistenceManager.init(AbstractBundlePersistenceManager.java:416)
> >         at
> >
> org.apache.jackrabbit.core.persistence.bundle.BundleDbPersistenceManager.init(BundleDbPersistenceManager.java:556)
> >         at
> >
> org.apache.jackrabbit.core.persistence.bundle.DerbyPersistenceManager.init(DerbyPersistenceManager.java:257)
> >         at
> >
> org.apache.jackrabbit.core.RepositoryImpl.createPersistenceManager(RepositoryImpl.java:1175)
> >         at
> >
> org.apache.jackrabbit.core.RepositoryImpl.createVersionManager(RepositoryImpl.java:354)
> >         at
> > org.apache.jackrabbit.core.RepositoryImpl.<init>(RepositoryImpl.java:282)
> >         at
> > org.apache.jackrabbit.core.RepositoryImpl.create(RepositoryImpl.java:573)
> >
>
> --
> View this message in context:
> http://www.nabble.com/Repository-startup-error-tp17914330p19590285.html
> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
>
>


-- 
---------------------
Michael Harris

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message