jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zhonglf <zhong.lu...@gmail.com>
Subject Re: Too slow - adding 1,000 node into the repositroy
Date Fri, 18 Jul 2008 09:59:51 GMT

Thank you, i will try to config the file data store right now.


Alexander Klimetschek wrote:
> 
> Are you using a bundle DB persistence manager (recommended)? And do
> you have binary properties (in which case a DataStore is useful)? Have
> a look at these wiki pages:
> 
> http://wiki.apache.org/jackrabbit/PersistenceManagerFAQ
> http://wiki.apache.org/jackrabbit/DataStore
> 
> Regards,
> Alex
> 
> On Fri, Jul 18, 2008 at 11:07 AM, zhonglf <zhong.lunfu@gmail.com> wrote:
>>
>> I am using a single session instance to add a large number of nodes in a
>> "flat" structure (the nodes are consist of about 7 simple properties
>> (Strings mostly, and a documents)). At first, adding 1,000 node took 200
>> seconds, when repository was empty.Until the size of nodes in the
>> repository
>> over 100,000, adding 1,000 node took more than 10 minutes. Why ? Any
>> ideas
>> to improve it?
>>
>> PS: I didn't add all nodes in one parent node, instead of using a node as
>> a
>> folder for per 200 children nodes.
>> --
>> View this message in context:
>> http://www.nabble.com/Too-slow---adding-1%2C000-node-into-the-repositroy-tp18525321p18525321.html
>> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
>>
>>
> 
> 
> 
> -- 
> Alexander Klimetschek
> alexander.klimetschek@day.com
> 
> 

-- 
View this message in context: http://www.nabble.com/Too-slow---adding-1%2C000-node-into-the-repositroy-tp18525321p18525622.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message