jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SY-1 <tyler2002...@yahoo.fr>
Subject Jackrabbit on JBOSS
Date Thu, 03 Jul 2008 15:28:28 GMT

Hi all!
Jackrabbit on JBOSS
I ve just started working with JackRabbit,currently i ve found some trouble
on the jackrabbit's deployment on JBOSS
i followed all the instructions posted on jackrabbit wiki and it appears
that the server starts correctly (the repository is created ,the workspace
is initialized etc..) but when i tried to make a lookup in my Java code i
have the following messages:

xception in thread "main" javax.naming.NameNotFoundException: jcrlocal not
bound
	at org.jnp.server.NamingServer.getBinding(NamingServer.java:529)
	at org.jnp.server.NamingServer.getBinding(NamingServer.java:537)
	at org.jnp.server.NamingServer.getObject(NamingServer.java:543)
	at org.jnp.server.NamingServer.lookup(NamingServer.java:296)
	at sun.reflect.GeneratedMethodAccessor77.invoke(Unknown Source)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
	at sun.rmi.transport.Transport$1.run(Transport.java:153)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
	at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
	at
sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
	at java.lang.Thread.run(Thread.java:595)
	at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(Unknown
Source)
	at sun.rmi.transport.StreamRemoteCall.executeCall(Unknown Source)

I ve tried everything but it still not working please if  you have any ideas 
reply to me Thank's 

i ve tried  to put the following lines into the jcr-ds-xml :
 <use-java-context>false</use-java-context>
But it returns to me a Null Pointor so as i said befor any i idea is
welcomed  thanks again

-- 
View this message in context: http://www.nabble.com/Jackrabbit-on-JBOSS-tp18260374p18260374.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message