jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pulla Venkat" <pcsri1...@gmail.com>
Subject Re: Cant create nodetypes
Date Thu, 19 Jun 2008 19:15:30 GMT
You need to add the namespace information at the begining of CND file.
Just like in xml file , namespace is specified before using , cnd file also
should be similar.

On Thu, Jun 19, 2008 at 2:59 PM, Nick Stuart <nstuart@speranzasystems.com>
wrote:

> Hi all, I've looked around for this problem, but all I see related is
> JCR-888, but I'm not using the IBM jdk as listed there. My jave version is:
> java version "1.6.0_06"
> Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
> Java HotSpot(TM) 64-Bit Server VM (build 10.0-b22, mixed mode)
>
> I am trying to create a fairly simple custom node type with the following
> cnd:
> <sp='something_here'>
> <nt='http://www.jcp.org/jcr/nt/1.0'>
>
> [sp:processMarker]
>  mixin
>  - sp:inProcess (boolean)
>  = 'false'
>    autocreated
>
> [sp:folder] > nt:folder,sp:processMarker
>
> [sp:resource] > nt:resource,sp:processMarker
>
>
> I have two issues.
> First, if i leave <sp='something_here'> as it is, I get the exception shown
> in JCR-888 saying its not a registered namespace uri. Not helpful.
> Second, if I try <sp=''> then I just get sp: is not a registered namespace
> whenever I try to use sp:folder.
> Either way I am at an roadblock here. The rest of the process has gone
> great
> and is doing everything I need it to, but I would love to be able to add
> some custom logic/info here to make things fit better.
>
> Any ideas on what I could be doing wrong? I am using the 1.4.5 release from
> maven.
> Thanks!
> -Nick
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message