jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "H. Wilson" <wils...@randdss.com>
Subject Re: Deleting repository
Date Wed, 18 Jun 2008 18:08:12 GMT
Thank you very much for responding. I tried the following:

    * Verified the repository location and deleted it.
    * Logged into MySQL server and 'drop database jackrabbit_test;'
    * Ran program to verify it would error out because it couldn't
      connect to database... and it did.
    * Re-deleted the repository location that had started to create from
      above step.
    * Logged into MySQL server and 'create database jackrabbit_test;'
    * Ran program and saw old nodes outputted.
    * Created a new project directory copying over only source code,
      build file, libraries and config files. Ran and on the first time,
      I am still getting the original nodes outputted.

The last step confirmed it for me - clearly I am missing, or more likely 
mis-configuring, something on my end. I suspected that initially but I 
guess I was hoping for a response that would fill me in on some backup 
sort of directory this information might be hiding in. Or even something 
regarding the database in MySQL which I guess wouldn't be covered by 
this list anyways. Thanks for the pointers.

HW

Alexander Klimetschek wrote:
> Well, the persisted data must certainly still be somewhere on your
> hard drive. Maybe you deleted the wrong repository home directory or
> the wrong tables in the database? Did you try to use a new home
> directory location for jackrabbit?
>
> Regards,
> Alex
>
> On Wed, Jun 18, 2008 at 6:49 PM, H. Wilson <wilsonh@randdss.com> wrote:
>   
>> First time posting a question to this list... Bear with me, I will try to
>> give as much information as possible.
>>
>> I am currently working on a test program to familiarize myself with
>> Jackrabbit before incorporating it into our project. I am using MySQL as the
>> backend and I am running JackRabbit embedded. The purpose of my little test
>> program is to initialize a new TransientRepository, and populate it with
>> some nodes from a Beanshell file. In the test program, before I source the
>> Beanshell file to populate the repository, I make sure that the only node in
>> the repository is the jcr:system one. No need to do this step if it is
>> already populated. Then I output all the nodes and their properties
>> recursively. This part works great - no problems. Now I wanted to wipe out
>> this repository and rerun my program just to make sure that it indeed was
>> going to do what I expected. But it isn't... I deleted the repository home
>> directory, but when I rerun my program and get to the check for nodes other
>> than the jcr:system one, it still sees the nodes as they were populated the
>> first time I populated it! ( I tweaked the populating script to add
>> different values, which is how I know it is definitely using the old
>> values.)  Yes I am logging out of the session and even calling shutdown. I
>> have tried the following in an attempt to get it to ignore those previous
>> values:
>>
>>   * Deleted the repository home directory.
>>   * "  and drop the mysql database it was accessing and re-creating it.
>>   * "  and drop the mysql database, and creating one with a new name,
>>     and changing the URL access string to match the new database.
>>   * Used the GarbageCollection methods at the end - scan, stopScan,
>>     deleteUnused..
>>   * Rebooted in the thought that something was hanging on in my memory.
>>
>> For every single combination of attempts, when I rerun my program and get to
>> that check for more than the jcr:system node, I get the same results - the
>> old nodes are somehow still there. As if it truly isn't being deleted. I am
>> getting no exceptions or errors. I have scoured the mailing lists, wiki, JR
>> website and googled and can't seem to find any pertinent information. Should
>> this be happening? Have I missed something? Any pointers would be greatly
>> appreciated.
>>
>> HW
>>
>>     
>
>
>
>   

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message