jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ZeroFactor <DavidDi...@gmail.com>
Subject Having trouble using repository.xml
Date Fri, 13 Jun 2008 14:37:41 GMT

I'm trying to set up a test application using Jackrabbit and I'm having
trouble using the repository.xml file.  I haven't had any problems using the
TransientRepository.  I'm using the repository.xml file that is located in
src.main.config.  

Here is the relevant code segment:
        String configFile = "c:/dev/config/jackrabbit/repository.xml";
        String repHomeDir = "c:/dev/config/jackrabbit/repository";

        Hashtable env = new Hashtable();
        env.put(Context.INITIAL_CONTEXT_FACTORY,
"org.apache.jackrabbit.core.jndi.provider.DummyInitialContextFactory");
        env.put(Context.PROVIDER_URL, "localhost");
        try {
            InitialContext ctx;
            ctx = new InitialContext(env);
            RegistryHelper.registerRepository(ctx, "repo", configFile,
repHomeDir, true);

Here is the output with the error message at the bottom:
93 [main] INFO org.apache.jackrabbit.core.RepositoryImpl - Starting
repository...
109 [main] INFO org.apache.jackrabbit.core.fs.local.LocalFileSystem -
LocalFileSystem initialized at path
c:\dev\config\jackrabbit\repository\repository
234 [main] INFO org.apache.jackrabbit.core.nodetype.NodeTypeRegistry - no
custom node type definitions found
250 [main] INFO org.apache.jackrabbit.core.fs.local.LocalFileSystem -
LocalFileSystem initialized at path
c:\dev\config\jackrabbit\repository\version
703 [main] INFO
org.apache.jackrabbit.core.persistence.bundle.util.ConnectionRecoveryManager
- Database: Apache Derby / 10.2.1.6 - (452058)
703 [main] INFO
org.apache.jackrabbit.core.persistence.bundle.util.ConnectionRecoveryManager
- Driver: Apache Derby Embedded JDBC Driver / 10.2.1.6 - (452058)
1343 [main] INFO org.apache.jackrabbit.core.RepositoryImpl - initializing
workspace 'default'...
1343 [main] ERROR org.apache.jackrabbit.core.RepositoryImpl - Failed to
initialize workspace 'default'
org.apache.jackrabbit.core.config.ConfigurationException: Configured bean
implementation class org.apache.jackrabbit.core.fs.local.              
LocalFileSystem was not found.: org/apache/jackrabbit/core/fs/local/              
LocalFileSystem: org/apache/jackrabbit/core/fs/local/              
LocalFileSystem
        at
org.apache.jackrabbit.core.config.BeanConfig.newInstance(BeanConfig.java:114)

I'm doing this all within NetBeans 6.1 on WinXP if that makes any
difference.

I'm really looking forward to using this great product.  Any help would be
appreciated.

Thanks,
Dave

-- 
View this message in context: http://www.nabble.com/Having-trouble-using-repository.xml-tp17824929p17824929.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message