jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From phoebe <phoebep...@gmail.com>
Subject Jackrabbit + Tomcat - can't create repository.
Date Tue, 10 Jun 2008 20:12:56 GMT

Hello everyone.

I have downloaded and install jackrabbit, but I can't get it to create a
default repository.
I expanded jackrabbit-webapp-1.4.war to a dir under
http://hostname/jackrabbit/ 
and for testing I chmod a+w the directory just in case.
A copy of jcr-1.0.jar is install in tomcat/share/lib.

When I tried to create a new repository, it claims that it already exists
and if I tried to access it, it claims it does not exist. In tomcat's log:
10.06.2008 15:33:58 *ERROR* Installer: Error while installing new repository
config 'jackrabbit/repository.xml': java.io.FileNotFoundException:
jackrabbit/repository.xml (No such file or directory) (Installer.java, line
153)

I modified Installer.java and to print stack trace:
java.io.FileNotFoundException: jackrabbit/repository.xml (No such file or
directory)
    at java.io.FileOutputStream.open(Native Method)
    at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
    at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
    at
org.apache.jackrabbit.j2ee.Installer.installRepositoryConfig(Installer.java:188

The docs and the src both say that default configs will be created. Where
are these directories relative to?

What are ${rep.home}, ${wsp.name} when jackrabbit is started by tomcat?

I tried various combinations to no avail. What do I have to do to make it
run in the most generic setting?

I got first hop to run, but I need a web service to manage and serve ~60M
data items (xml or images)
 to multiple dynamically generated html.
Before I spent too much more time on this, Is this the correct tool?
I looked at sling too. It is too heavy for what I need.

Thanks in advance, Phoebe.




-- 
View this message in context: http://www.nabble.com/Jackrabbit-%2B-Tomcat---can%27t-create-repository.-tp17763713p17763713.html
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message