jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject Re: [ANNOUNCE] jackrabbit-core 1.4.1 released
Date Thu, 21 Feb 2008 11:35:33 GMT
Hi,

On Thu, Feb 21, 2008 at 1:22 PM, sktkaur <sumanjeet23@gmail.com> wrote:
>  earlier i was using jakarta slide.
>  now i want to shift to jackrabbit n i got to know that jackrabbit-core 1.4.1
>  is released.
>  should i directly download jackrabbit-core-1.4.1.jar or i have to do
>  something else.

It depends on what you want to do. The easiest way to get started with
Jackrabbit is to download the jackrabbit-webapp-1.4.war and deploy it
to a servlet container like Tomcat (note that you need to have
jcr-1.0.jar in the shared classpath for that to work). You can upgrade
that installation to use the new jackrabbit-core 1.4.1 component by
replacing the jackrabbit-core jar in WEB-INF/lib within the war file.

Alternatively, if you want to embed Jackrabbit in your application and
you use Maven 2 as the build environment, you can simply declare the
following dependencies and Maven takes care of the rest:

    <dependency>
      <groupId>javax.jcr</groupId>
      <artifactId>jcr</artifactId>
      <version>1.0</version>
    </dependency>
    <dependency>
      <groupId>org.apache.jackrabbit</groupId>
      <artifactId>jackrabbit-core</artifactId>
      <version>1.4.1</version>
    </dependency>

>  n when i download that an error message appeares that "The page you were
>  trying to reach does not exist.you may want to try a search or browse the
>  site to find the page you were looking for".

Sorry about that, our new Confluence-based web site is playing tricks
on us. I'll fix the links, but meanwhile you can find the release by
following the links at
http://www.apache.org/dyn/closer.cgi/jackrabbit/.

BR,

Jukka Zitting

Mime
View raw message