jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominique Pfister" <dominique.pfis...@day.com>
Subject Re: Clustering and .lock file
Date Thu, 06 Dec 2007 08:09:56 GMT
Hi Michael,

This sounds like having two repositories using the same home
directory. The only thing that should be shared between two clustered
instances are: the location of the persistent storage and the journal.
Please make sure, that your web application's web.xml contains unique
repository-home parameters.

Kind regards
Dominique

On 05/12/2007, Michael Wechner <michael.wechner@wyona.com> wrote:
> Hi
>
> I am trying to run my webapp within a Tomcat (5.0.30) cluster with two
> nodes.
>
> According to http://wiki.apache.org/jackrabbit/Clustering
> each cluster node is loading its own repository.xml file resp.
> repository-cnode1.xml for node1 and repository-cnode2.xml for node2,
> whereas I have added the Cluster config to each repository config, e.g.
>
>  <Cluster id="cnode2">
>     <Journal class="org.apache.jackrabbit.core.journal.DatabaseJournal">
>       <param name="path" value="${rep.home}/revision.log"/>
>       <param name="url" value="jdbc:derby:${wsp.home}/db;create=true"/>
>     </Journal>
>   </Cluster>
>
> for repository-cnode2.xml.
>
> When I startup the first node everything is fine, but when I startup the
> second node, then the log file tells me that it has a .lock detected and
> the repo already seems to be in use and hence cannot be used:
>
> 26237 2007-12-05 20:59:19,377 [http-9290-Processor25] WARN
> org.apache.jackrabbit.core.util.RepositoryLock.acquire():111  - Existing
> lock file /home/michi/src/wyona-svn/wyona/misc/foaf/jackrabbit/.lock
> detected. Repository was not shut down properly.
> 26265 2007-12-05 20:59:19,405 [http-9290-Processor25] ERROR
> org.wyona.yarep.impl.repo.jcr.JCRRepository.readConfiguration():326  -
> The repository home /home/michi/src/wyona-svn/wyona/misc/foaf/jackrabbit
> appears to be in use since the file named .lock is locked by another
> process.
>
> I thought the Cluster config would take care of this, but maybe I added
> it at the wrong position resp. within the wrong file. Is it possible
> that this also needs to be added to the
> jackrabbit/workspaces/default/workspace.xml file?
> And if so, how can this be referenced resp. duplicated?
>
> Resp. where exactly needs the Cluster config to be placed?
>
> Thanks
>
> Michael
>
> --
> Michael Wechner
> Wyona      -   Open Source Content Management   -    Apache Lenya
> http://www.wyona.com                      http://lenya.apache.org
> michael.wechner@wyona.com                        michi@apache.org
> +41 44 272 91 61
>
>

Mime
View raw message