jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hendrik Beck \(camunda\)" <hendrik.b...@camunda.com>
Subject AW: Glassfish and Windows XP. Hopeless?
Date Mon, 03 Dec 2007 21:48:06 GMT
Hi Debbie!

 

Only a quick answer about Windows and Glassfish: I had the very same trouble
you just experienced. I only needed Jackrabbit on Glassfish for some testing
issues so after spending too much time on it I ended up installing Linux on
a VMWare L But after that I followed Daniel’s installation guide and
everything worked fine for me as far as I remember (it was some months ago).
I didn’t have any trouble neither during installation nor afterwards.

 

I am afraid that doesn’t help a lot but I just wanted to share that
experience…

 

Regards

Hendrik

 

 

Von: Debbie Troxel [mailto:dtroxel@e-tractions.com] 
Gesendet: Montag, 3. Dezember 2007 22:37
An: users@jackrabbit.apache.org
Betreff: Glassfish and Windows XP. Hopeless?

 

I have been investigating Jackrabbit and would really like to be able to use
it but have been extremely frustrated trying to get an environment that
works.

Others seem to have run into the same issues, but I haven't found any
pointers to resolutions.  Is it hopeless to try to run under Glassfish on
Windows XP?  

It looks like the ideal approach would be to use the Resource Adapter.  I've
installed it successfully on linux, but under Windows, I get 
com.sun.enterprise.deployment.backend.IASDeploymentException:
java.io.IOException: filename:
C:\Java\Sun\SDK\domains\domain1\applications\j2ee-modules\jackrabbit-jca\lic
ense\LICENSE  
java.io.FileNotFoundException: (The system cannot find the path specified)

This looks like the issue documented by Daniel BrŸuen in this post:
http://www.nabble.com/Jackrabbit-RAR-Deployment-in-Glassfish-(and-on-Mac-OS-
X)-t4334860.html
Windows also has a case insensitive filesystem so apparently the license
folder and LICENSE file collide.  Is there any workaround for Windows?  

Giving up on that approach, I tried a Model 2 deployment, and again ran into
the same issues others have reported.  I installed all the required jars and
created a JNDI reference named 'jcr/testRepository' bound to
org.apache.jackrabbit.core.jndi.BindableRepositoryFactory.

In my webapp, I look up the Repository using
            InitialContext context = new InitialContext();
            Context environment = (Context) context.lookup("java:comp/env");
            Repository repository = (Repository)
environment.lookup("jcr/testRepository");

It works initially, but if I make any changes and redeploy my webapp, I get
the .lock error:
javax.jcr.RepositoryException: The repository home C:\Java\jackrabbit\test
appears to be in use since the file named .lock is locked by another
process.  The only solution seems to be restarting Glassfish every time I
want to redeploy, which is not practical.

This problem is very similar to this thread, but I don't see any solution
there.
http://www.nabble.com/Repository-Lock-Problem-in-JEE-Environment-tf4312389.h
tml#a12308562

So am I just out of luck on Windows / Glassfish?

If so, my next approach would be to look at Model 3 deployment, but I see
every recent post asking for help or pointers to a Model 3 solution have
gone unanswered, so that's not too encouraging either.  It appears that RMI
is dismissed as too slow, and I'm not very familiar with WebDAV, so I'm not
sure if that's something I should be pursuing.  

I would really appreciate any suggestions or help.
Thanks so much,
Debbie


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message