jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Mitterdorfer <daniel.mitterdor...@salzburgresearch.at>
Subject Re: XPath query returns no results
Date Mon, 19 Nov 2007 11:51:49 GMT
Christoph Kiehl wrote:
> Daniel Mitterdorfer wrote:
>
>> If I query for all nodes using the XPath query '//*', I get all nodes 
>> in the repository. So far, so good. However, if i want to query only 
>> for the 'interedu' subtree using the XPath query '//interedu/*' i get 
>> no results although 'interedu' has child nodes. I have already tried 
>> quite a few things but got no sufficient results (including a 
>> research on the Jackrabbit mailing lists). Can anybody see my 
>> error(s) or give me some pointers? Thanks!
>
> I'm not an XPath expert and it might be a bug, that the above doesn't 
> work. But until then try 'interedu/*' or '/jcr:root/interedu/*'. 
> Relative queries are always relative to the root node.
>
> Cheers,
> Christoph
>
Hi Christoph,

Thanks for your response. I just tried both queries. Unfortunately, 
neither of them returned a result. :-(

Bye,

Daniel

Mime
View raw message