jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Custer <acus...@gmail.com>
Subject Problems building 1.3.3 and 1.3.1
Date Sat, 10 Nov 2007 11:09:21 GMT
Hey all,

Thanks for the work on jackrabbit.

Trying to get it to build by downloading the -src jar files and doing
maven installs. I'm using maven 2.0.5 and have tried java 1.5 and 1.6
(Sun SDK's). Both 1.3.3 and 1.3.1 fail in the same way, in 
  jackrabbit-core/ working on the .query. stuff. 

Perhaps I am missing a lib? I've tried mvn -U install but that didn't 
help. Any suggestions would be appreciated.

--adrian




1.3.1 fails with:
----------------

[INFO] Compiling 442 source files
to /soft/Java/jackrabbit/jackrabbit-1.3.1/jackrabbit-core/target/classes
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Compilation failure

/soft/Java/jackrabbit/jackrabbit-1.3.1/jackrabbit-core/src/main/java/org/apache/jackrabbit/core/query/sql/ASTIdentifier.java:[21,35]
cannot find symbol
symbol: class SimpleNode
public class ASTIdentifier extends SimpleNode {

/soft/Java/jackrabbit/jackrabbit-1.3.1/jackrabbit-core/src/main/java/org/apache/jackrabbit/core/query/sql/ASTIdentifier.java:[29,23]
cannot find symbol
symbol  : class JCRSQLParser
location: class org.apache.jackrabbit.core.query.sql.ASTIdentifier
...

(a couple of hundred more in query.sql and query.xpath )


Mime
View raw message