jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stefan81 <stefan.schla...@process-relations.com>
Subject Re: RMI connection
Date Wed, 05 Sep 2007 13:49:35 GMT

Hi,

as it seems, I face the same problems like Marcel. I also get the following
exception when trying to access the repository on JBoss via RMI by
rmi://localhost:1099/jcrServer:

non-JRMP server at remote endpoint

Are there any new insights which might help me with the problem? 


Marcel Dullaart-2 wrote:
> 
> Hi all,
> 
> I have setup a JBoss server instance and placed the
> jackrabbit-jca-1.2.3.rar and jackrabbit-jcr-rmi-1.2.3.jar in its
> deploy directory. From the, I removed the jcr-1.0.jar from
> jackrabbit-jca-1.2.3.rar and placed it in the server's lib diretory,
> also have I created a datasource connector (*-ds.xml) file and placed
> that in the deploy directory as well.
> JBoss start fine without errors.
> 
> Then I tried to connect to it using the jcrClient (contrib), using
> jndi jcrServer, which succeeded.
> But I need an RMI connection so in the jcrClient I tried connect
> rmi://localhost:1099/jcrServer. This failed with the message:
> exception: java.rmi.ConnectIOException
> message: non-JRMP server at remote endpoint
> 
> When using the jcrBrowser plugin from eclipse I get the same results.
> 
> Can someone please explain to me what is wrong here?
> 
> 
> Thanks in advance,
> Marcel
> 
> 

-- 
View this message in context: http://www.nabble.com/RMI-connection-tf3611478.html#a12498460
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message