jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Mueller" <thomas.tom.muel...@gmail.com>
Subject Re: Problem with DerbydbPersistanceManager
Date Mon, 20 Aug 2007 14:21:20 GMT
Hi,

Sorry I didn't see this first. You have posted the list of jar files
in your web app lib directory. There are multiple versions of the same
software. This might be the problem.

-jackrabbit-1.0
-jackrabbit-1.3-src
-jackrabbit-core-1.3
(remove jackrabbit-1.0.jar)

-jackrabbit-index-filters-1.2.1
(not sure if this is required? better remove it)

-slf4j-log4j12-1.0
-slf4j-log4j12-1.3.0
(I don't think you need both files, remove slf4j-log4j12-1.0)

-lucene-1.4.3
-lucene-core-2.0.0
(remove lucene-1.4.3.jar)

I hope this helps,
Thomas



On 8/20/07, Jaick <jaick@hotmail.fr> wrote:
>
> Sorry, I look everywhere and I don't find other Jackrabbit's jar files.
> In google I don't find any answer...  :-(
> I'm lost in the middle of nowhere !
>
>
>
>
> Thomas Mueller-6 wrote:
> >
> > Hi,
> >
> >> too
> >
> > There should be only one set of jar files. You will get problems if
> > there are multiple jar files in different folders, and if there are
> > some version problems. You will find more information about that if
> > you do a Google search for 'tomcat class cast exception'.
> >
> > Thomas
> >
> >
> > On 8/20/07, Jaick <jaick@hotmail.fr> wrote:
> >>
> >> Hi Thomas,
> >>
> >> I placed the Jackrabbit jar file in the webapp/WEB-INF/lib folder too.
> >> Here is the list of all my jars files :
> >>
> >> -common-codec-1.2
> >> -common-collections-3.1
> >> -commons-httpclient-3.0
> >> -concurrent-1.3.4
> >> -derby-10.2.1.6
> >> -fontbox-0.1.0-dev
> >> -geronimo-jta_1.0.1B_spec-1.0.1
> >> -jackrabbit-1.0
> >> -jackrabbit-1.3-src
> >> -jackrabbit-api-1.3
> >> -jackrabbit-classloader-1.3
> >> -jackrabbit-core-1.3
> >> -jackrabbit-index-filters-1.2.1
> >> -jackrabbit-jcr-commons-1.3
> >> -jackrabbit-jcr-rmi-1.3
> >> -jackrabbit-jcr-server-1.3
> >> -jackrabbit-jcr-tests-1.3
> >> -jackrabbit-text-extractors-1.3
> >> -jackrabbit-webdav-1.3
> >> -jcl104-over-slf4j-1.3.0
> >> -jcr-1.0
> >> -log4j-1.2.8
> >> -lucene-1.4.3
> >> -lucene-core-2.0.0
> >> -nekohtml-0.9.4
> >> -pdfbox-0.6.4
> >> -slf4j-api-1.3.0
> >> -slf4j-log4j12-1.0
> >> -slf4j-log4j12-1.3.0
> >> -tm-extractors-0.4
> >> -xercesImpl-2.8.1
> >> -xml-apis-1.3.03
> >> -xmlParserAPIs-2.0.2
> >>
> >> I don't think that the problem is here.
> >> Thanks anyway
> >>
> >> Jaick
> >>
> >>
> >>
> >> Thomas Mueller-6 wrote:
> >> >
> >> > Hi,
> >> >
> >> > I am not sure, but maybe the problem has to do with the Tomcat
> >> > classloader. Could you check that the jar files are in the right
> >> > directories. In my system, I have
> >> >
> >> > server/lib: no jackrabbit jar files
> >> > shared/lib: no jackrabbit jar files
> >> > webapps/<app>/WEB-INF/lib: jackrabbit and related jar files
> >> >
> >> > Thomas
> >> >
> >> > On 8/20/07, Jaick <jaick@hotmail.fr> wrote:
> >> >>
> >> >> Hello,
> >> >>
> >> >> I don't find anything about my error, and I really need to know what
I
> >> >> have
> >> >> to do.
> >> >> I use Jackrabbit 1.3.
> >> >> Last month I ran Jackrabbit as Java application and there was no
> >> problem
> >> >> with the database but now running Jackrabbit on Tomcat 5.5 throws this
> >> >> RepositoryException. Why is there any problem with the derby database
> >> in
> >> >> this case ?
> >> >> Maybe someone can help me ?  :confused:
> >> >>
> >> >> Thank a lot
> >> >>
> >> >> (please forgive my bad english, I'm a french studient)
> >> >>
> >> >>
> >> >>
> >> >>
> >> >>
> >> >> Jaick wrote:
> >> >> >
> >> >> > Hi everybody,
> >> >> >
> >> >> > I'm new in Jackrabbit !
> >> >> > I work in a custom webapp which use Documentum for document storage.
> >> I
> >> >> > have to replace Documentum with Jackrabbit. My application run
with
> >> >> Apache
> >> >> > Tomcat 5.5 Server. When I want to start Tomcat and register the
> >> >> Jackrabbit
> >> >> > repository with : "RegistryHelper.registerRepository(ctx, "repo",
> >> >> > configFile, repHomeDir, true);"
> >> >> >
> >> >> > I have these errors :
> >> >> >
> >> >> > javax.jcr.RepositoryException: Cannot instantiate persistence
> >> manager
> >> >> > [...]
> >> >> > Caused by: java.lang.ClassCastException:
> >> >> > [...]
> >> >> >
> >> >> >
> >> >> > Here is my repository.xml file :
> >> >> >
> >> >> >
> >> >> >
> >> >> > <Repository>
> >> >> >     [...]
> >> >> > </Repository>
> >> >> >
> >> >> >
> >> >> > Someone knows what's happen ?
> >> >> > I don't understand why the cause of this exception comes from
> >> >> > "java.lang.ClassCastException" !
> >> >> >
> >> >> > Thank you !
> >> >> >
> >> >> > Jaick
> >> >> >
> >> >> --
> >> >> View this message in context:
> >> >>
> >> http://www.nabble.com/Problem-with-DerbydbPersistanceManager-tf4286890.html#a12232034
> >> >> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
> >> >>
> >> >>
> >> >
> >> >
> >>
> >> --
> >> View this message in context:
> >> http://www.nabble.com/Problem-with-DerbydbPersistanceManager-tf4286890.html#a12232668
> >> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
> >>
> >>
> >
> >
>
> --
> View this message in context: http://www.nabble.com/Problem-with-DerbydbPersistanceManager-tf4286890.html#a12236121
> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
>
>

Mime
View raw message