jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From qcfireball <qcfireb...@yahoo.com>
Subject RE: Model 2 Deployment Problems
Date Mon, 13 Aug 2007 22:42:45 GMT

I will post my server config tomorrow when I get in to work.  I will also try
to get log4j configured for jackrabbit.  1) where do I get the log4j.xml
from?  Is it in the jackrabbit sources?  2) I am using Tomcat 6, so there is
no [Tomcat]/common/classes.  I will look into the new "config" for Tomcat 6
and see where this went.

I also forgot to mention, that I am trying to set this up on top of an
already created repository.  So, "repHomeDir" already has stuff in it.

In response to the other post on this topic, is there a way to see the JNDI
tree in tomcat?  Or would I have to code this myself?

Thanks.



sbarriba wrote:
> 
> * Can you post your server config?
> * Worth setting up log4j at the app server level to debug out JackRabbit
> logging. For Tomcat 5 this is achieved by putting a log4j.xml in
> [Tomcat]/common/classes.
> * Is anything getting created in the configured "repHomeDir" (the
> repository
> directory)?
> Regards,
> Shaun
> 
> -----Original Message-----
> From: qcfireball [mailto:qcfireball@yahoo.com] 
> Sent: 13 August 2007 20:01
> To: users@jackrabbit.apache.org
> Subject: Model 2 Deployment Problems
> 
> 
> I am attempting to do a Model 2 deployment, but when I retrieve the
> Repository like this:
> 
>         final InitialContext context     = new InitialContext();
>         final Context environment = (Context)
> context.lookup("java:comp/env");
>         final Repository repository  = (Repository)
> environment.lookup("jcr/repository");
>         return repository;
> 
> I get the following error:
> 
> SEVERE: jsp: Error retrieving Repository JNDI Object jcr/repository
> javax.naming.NamingException: Cannot create resource instance
> at
> org.apache.naming.factory.ResourceEnvFactory.getObjectInstance(ResourceEnvFa
> ctory.java:114)
> at
> javax.naming.spi.NamingManager.getObjectInstance(NamingManager.java:304)
> at org.apache.naming.NamingContext.lookup(NamingContext.java:793)
> at org.apache.naming.NamingContext.lookup(NamingContext.java:140)
> at org.apache.naming.NamingContext.lookup(NamingContext.java:781)
> at org.apache.naming.NamingContext.lookup(NamingContext.java:153)
> 
> I am using Tomcat 6.0.13, Jackrabbit 1.3
> 
> I followed the application howto and the model 2 howto, and tomcat starts
> up
> with no errors in the logs.
> -- 
> View this message in context:
> http://www.nabble.com/Model-2-Deployment-Problems-tf4263029.html#a12131983
> Sent from the Jackrabbit - Users mailing list archive at Nabble.com.
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Model-2-Deployment-Problems-tf4263029.html#a12135633
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message