jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From qcfireball <qcfireb...@yahoo.com>
Subject Model 2 Deployment Problems
Date Mon, 13 Aug 2007 19:01:22 GMT

I am attempting to do a Model 2 deployment, but when I retrieve the
Repository like this:

        final InitialContext context     = new InitialContext();
        final Context environment = (Context)
context.lookup("java:comp/env");
        final Repository repository  = (Repository)
environment.lookup("jcr/repository");
        return repository;

I get the following error:

SEVERE: jsp: Error retrieving Repository JNDI Object jcr/repository
javax.naming.NamingException: Cannot create resource instance
at
org.apache.naming.factory.ResourceEnvFactory.getObjectInstance(ResourceEnvFactory.java:114)
at javax.naming.spi.NamingManager.getObjectInstance(NamingManager.java:304)
at org.apache.naming.NamingContext.lookup(NamingContext.java:793)
at org.apache.naming.NamingContext.lookup(NamingContext.java:140)
at org.apache.naming.NamingContext.lookup(NamingContext.java:781)
at org.apache.naming.NamingContext.lookup(NamingContext.java:153)

I am using Tomcat 6.0.13, Jackrabbit 1.3

I followed the application howto and the model 2 howto, and tomcat starts up
with no errors in the logs.
-- 
View this message in context: http://www.nabble.com/Model-2-Deployment-Problems-tf4263029.html#a12131983
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message